New to ROON vis QNAP ROON Server - No music imported after 24 hours [SOLVED]

I have exported my music collection out of my Meridian Sooloos MC600 to a QNAP TS-670 Pro (which is named 4TA-MEDIA-QNAP with a one volume configuration (Volume1). I have Microsoft directory services active on the QNAP so I think have SMB running.

I created a shared drive named RoonServer (smb:\Volume1\RoonServer). Sooloos exported all my music (circa 580 albums/15,000 tracks) to a sub-folder of the RoonShare folder named Artists - it took a couple of days. The music is stored hierarchically by artist and then by album - each being a separate folder. It has a massive VariousArtists folder. I have checked and it appears that each of the album folders is populated with FLAC tracks (although there are other formats too).

I installed the Qpkg file to install QNAP Roon Server v1.02.

I installed Roon App on my MacPro which is on the same wired network. I choose to use the Mac OS app as a remote control. I have created 2 Watched Folders (smb:\Volume1\RoonServer and smb:\Volume1\RoonServer\Artists). I am already a Tidal subscriber, so logged in and selected some Tidal genres. Tidal albums started to populate in my Roon Overview page immediately.

I left it overnight and started to see about 570 albums pop up. I started spot checking, for example the albums of Adele of which on my Sooloos server I have 4 - yet only 1 appears. I have loads of Midnight Oil albums but none appeared. So I logged out of Tidal. That resulted in no albums being displayed.

So it does not appear that the QNAP Server is importing my music. Your assistance to help import my music would be greatly appreciated.

This is the file path to my QNAP

Not sure if this helps.


As you have Roon Server running on the QNAP (which is also where the drives are) the Roon Watched folder should be pointing at the local path not a network share.

Many thanks to Chris and Carl. I changed the nature of the Watched Folders but still no joy - see screen shot below. Using the ANAP File Manager I can still see the folder and all the files. Any further thoughts?

Shouldn’t it be /share/RoonServer?

1 Like

I would not put the music in the roon server folder, it should be on another volume where your normal shares are…at least that is my understanding. Roon server share should be a SSD drive, the music can be on a normal raided volume.


Use a share called Roon_Server to keep your music files in. See my earlier pic and the knowledge base for the file path.
The Qpkg is on an SSD on my QNAP

Your image is Roon_Music…don’t confuse the poor fella :tired_face:

Assuming you haven’t a) changed the default QNAP shares and b)are actually storing files in these shares, your default local path would be /share/Multimedia/Music

S[quote=“Paul_Chatfield, post:6, topic:19001, full:true”]
I would not put the music in the roon server folder, it should be on another volume where your normal shares are…at least that is my understanding. Roon server share should be a SSD drive, the music can be on a normal raided volume.

For testing purposes I would create a new shared folder on the Qnap called “my music” for example, it doesn’t matter what level it is e.g. Under volume1, or multimedia or whatever you choose, once created you can copy just one artist to it then mount it as a local folder /share/your folder path and see if Roon adds it.


Hi Russ - your assistance greatly appreciated.

Unfortunately - no joy - Roon did not add the artist/album/tracks for one album. I do not have a separate SSD drive attached but I will try to source one. But it should work, albeit not optimally, without?

Any further diagnostics to suggest?

Thanks to Russ who has kindly assisted me offline and helped solve the issue. In brief, if you have installed Roon Server software on your QNAP besides the other advice (e.g. using an SSD, min. RAM and processor etc.) when creating Watched Folders, you need to:

Open Settings -> Storage
In the Watched Folder section - click on Add Folder
In the new splash window click on Add Local Folder at the bottom of screen (do create as a Networked Folder)
On the next splash screen, complete the path field with


Then click Add Folder

My mistake was to omit the /share/ at the front end. Now Roon busily importing music as I write.

Many thanks to Russ and all the other kind assistance.

1 Like

Hi Adrian,
I am glad your setup is working now. I’d like to add, that I would not recommend to globally add the “/share” path.

You should also specify the shared folder name in the path. If you have your music stored in the shared folder “Music”, you should add it as


as described in NAS installation instructions.
Otherwise it could lead to duplicates and adding unwanted media files. The “/share” directory holds links to your shares but also to the volumes, so these will be double indexed by adding only “/share”.

Hi Chris - had missed that in the NAS installation instructions. Also in my original post the shared folder was in between greater than and less than signs - and did not appear. Have corrected it now. Many thanks.

Looking forward to v1.3…

Kind regards

1 Like