New (was back in 2021) iFi Zen Stream device

I went from the 15v standard PSU to the 12v iPower X and I find it cooler to the touch.
Now that I swapped the MA Mini I Pro 3 with the Zen neither get as much play as I am in the office most days. So I turn them both off when not in use
Both work great and would be happy with either


Question; I had a Zen Stream and returned it. I was using it USB out to Denafrips Iris, I2S to Pontus II. I used it hardwired in AIO mode with Roon (because I found all other options sucked), and I simply went to the unit and flipped the toggle switch in the back to Roon exclusive mode and the result was no sound. Apparently it defaulted to coax. I tried opening device set up in Roon and it didn’t allow me to switch output. I tried opening the iFi app and it crashed about 10 times. Is this consistent with you all’s experience? Work arounds? I’d like to use it but found UI to be terrible.

Yes I think the same, it is not the most intuitive…

In mode 2, roon mode the device setup it is locked to spdif, to switch output you have to open the “device info” not “device setup”. That gives you a splash screen with info and a link to the web interface for iFi’s roon where you can change the output. Just to be sure, this is not working for you? here are some screen shots just in case:

the ZS in the audio settings in roon:
Screenshot 2022-11-30 at 06.10.08
this device info:
Screenshot 2022-11-30 at 06.00.06
the screen device info is opening:
Screenshot 2022-11-30 at 06.00.17
the web interface:

here I can change the output:
Screenshot 2022-11-30 at 06.11.23

Hope this is your problem and it helps

edit: now I had time to search for it, here is a far better explanation than what I managed New (was back in 2021) iFi Zen Stream device - #2400 by Steven_Klemow


This was due to a firmware change, and in the middle of this thread there is a long discussion about this change which was very difficult for people to work out.
But yes a lot of people had this issue at that time and it needed everyone to understand how to make it work and why Coax was made the default device output.
What @Traian_Boldea has pointed out is exactly right, and it was not a good decision in my mind


Thank you and @Michael_Harris for taking time to reply, both comments are helpful. The link to @Steven_Klemow set up guide is fantastic and I wish I’d seen this before! I have since bought a Naim ND5 XS 2 but it’s a euro version (didn’t think about that when I ordered it) so I am waiting on a step up converter. Now I am reconsidering my who digital side, not sure I am excited to implement a converter into my system. Anyway, thanks again.


Mine keeps going unresponsive.
Seems OK playing music but if you leave it for a period it’s powered on but you can’t turn it off and software does not see it. The only option is the pull the power.
I’ve done a hard reset on Ifi for some reason wanted me to use the bricked tool which I have questioned.

Hi Phil
I have to say I have never seen that with my unit running on Ethernet. Are you running Ethernet or WiFi?

Also AIO mode or ROON only mode?

I’m on ethernet and AIO mode, I’ve turned my LMS server off after a trial and play so I could put it back in Roon mode and see if it makes any difference.

1 Like

I have tried, mine didn’t freeze (I’ve tried over night). If you can’t turn it off, roon does not see it, can you access it via a web browser? (in AIO = ip adress, in Roon mode “ipadress”:3100)


Phil as Traian said try and do some basic testing, such as
ping ifil.local
(from the command prompt or shell on Windows or Mac)

also http://ifi.local from a Web Browser (while in AIO mode).

This will give an idea if it is a Zen/Roon issue or if the device is just crashing/dropping off the Network

1 Like

I’ll give that a try, but last time the app did not see it and it would not power down.
So far today its stayed up today.


Crashed again
I’ve changed the ethernet cable which is OK as I’ve installed it on my NAS.
Does not respond to ping or visible in iFi app or Roon.
Router shows disconnected, Ethernet port lights flashing.
Power and Network light on, power switch non responsive.
Dac has powered off as it can’t see anything from the Stream.
Pulling power only way to restore

I’m logging it all on my iFi service request and have requested a refund but they are not responding
other than asking me to run the un-bricking process which I’m reluctant to try, I’ve already done a hard reset.

Feels like that could be a hardware issue.

Sound’s like you are working your way through the right check’s, I can’t see what else you can look at (duplicate IP address, but that would be more obvious I think).

You can always try a different port on the switch, but that is more like preying for help

1 Like

I managed to find a Pi which should be here in a few days as a backup for when it goes back plus an old Sonos Connect. Not sure what my streamer plan is if they refund it….

Reliability has been good in the last year, but there were some early issues.

There are other options like the Argon Solo, Wiim mini or Wiim mini pro. But the last two are not Roon Ready yet


If anybody wants to connect ZS directly to the roon core.
For sure it works faster. Before I was connecting all in a switch (about 20m away), sometimes it was slow (when I was using upsampling to 125DoP).
I bought a USB-c to ethernet and connected with that the Mac mini roon core to the rest of the network (the switch). And from the Mac mini ethernet port I connected a 25cm cable to the ZS. Had to manually config ips for core ethernet (not the dongle) and for ZS. The downside is that the ZS it is no longer available on the main network, but I was using only ZS in roon mode anyway so for me it is the same.
It is an upgrade in speed clearly. Maybe is just my mind but 5% upgrade in SQ (ZS from Mac mini usb was 20%)
Next it will be to insert optical in the link between Roon Core and ZS
Thanks to @DanielAvasilichioaei here he posted all the config: Can a PC running Roon Core with dual network outlets be connected direct to my Lumin streamer? - #14 by DanielAvasilichioaei


Just bought a Zen Stream and wouldn’t have beem able to set it up without help from this article. Thank you


I’m glad it did work for you. Thank you for your kind words. I’m just late to the party, last to post.

Also thanks again to @Michael_Harris @Steven_Klemow and all who contributed to this threat and pls forgive me for not mentioning all the names


Welcome to the Roon forums @Bernard_Fromson, that sort of help is the forum at its best. Kudos to @Traian_Boldea for the help and for generously crediting others. I might finally get around to buying one myself…


Non Believer :rofl:
Welcome to the club @killdozer

1 Like