Nightmare installing Rock

Who ever created the guide to installing Rock onto a NUC… Not easy to follow…

I made a silly mistake and installed the programme onto the 1tb internal SSD and left the 128 m2 for the music files. But it showed up on my Mac when I got to the web set up.

Not sure what I needed to do, so I tried to set up again.

But now it’s not working, not showing up on my network and I have no idea what to do.

Any advice?

Somebody who knows what to do will respond, but I’m wondering if you can remove the 1TB SSD and reformat it, reinstall, then start over. Do you know if the 128 m2 got modified at all?

I have no idea. No idea at all why it shouldn’t work when I just reinstalled.

Spent hours trying to sort and so fed up.

I don’t really know, but I’m thinking that when doing the initial install attempt, you might have reformatted the 128 m2 as part of that process. If so, you might have lost something on that drive that is needed.

Again, someone who knows will respond, I hope. You might want to post this in the Support forum.

Maybe I can flag it @support

1 Like

I wrote that guide.

Hrm, is the guide not easy to follow or did you make a “silly mistake”? Tell me where it became difficult to follow, so I can fix it up.

What went wrong? We need more information than “it doesn’t work”.

Without any more information about what you did, I can suggest:

  • tell us what you did
  • show us photos of any errors or confusion along the way
  • try removing the 1tb drive and installing on the m.2 just to make sure no mistakes are made
2 Likes

I think this means he tried to install Roon a second time on the correct drive.

Hi.

Sorry if I sounded blunt, I am Autistic and was really fed up and my social niceties sometimes are not the best.

The first question is what is the correct boot order.
I have a M2 and SSD 1tb for my music.

Second is what does the software get installed onto? My guess is the M2.

Third - the left side of the text was missing on my tv for some reason. So I guessed. Incorrectly.

Forth, when the installation of the software ends, it says you will get an IP address, but nowhere in the docs does it state plug in a network cable during this part of installation. So originally I didn’t get an IP address. But managed to find the Ip with software.

So basically this worked but the drives were the wrong way around. The m2 was way too small for my collection.

But the Rock showed on my Mac when I went to continue the installation.

So I started again. Trying to do the same, but the software installed onto the correct drives. When you finally finish and it asks you to reboot there is no message about ip address, just some programming on screen.

When I finish and attach to my router, there is no sign of the Nuc. No ip address or anything.

Any help would be greatly appreciated

If you have a tablet or phone install a program called Fing on it. It will look on your network and find all of your devices network addresses including your nuc/rock.
This will allow you to complete the steps.

As to the instructions, they are clear if you know what you are doing and I guess the thought is if you didn’t know what you were doing you would be unlikely to try doing it :slight_smile:
But like nearly all technical documentation there is assumed knowledge.

1 Like

Yes, used Fing, it’s not there. Everything is easy when you know what to do !

Funnily enough I normally have no issues.

Ok
I’d disconnect the big drive.
Reinstall and have your phone handy to take pictures of anything you don’t understand or want guidance on and let us help in more real time.

That’s great. I have ordered a new hard drive i am going to fetch and will see what happens.

I cannot put a cat 5 lead in the back as I have to install using a tv. Will this be an issue not getting an IP address once ready?

It may well be. Is it plugged into a network cable now when you are trying to find it?

Hi,

I made a mistake and installed on the 1tb. Now my machine doesn’t seem to work.

No ip address, nothing.

Would this be because the OS is on both discs?

Yes. When trying to find it after install I put the lead in and it was found on network. But no IP address was on screen as I don’t have tv in pc room, so couldn’t put lead into in whilst install

When I tried to reinstall onto correct drive, did the same and impossible to find on the network. Nothing worked.

So purchased a new 1tb drive and going to start again. In their once the m2 has the software installed, it will be clean.

So final question when installing must it have a network cable attached ?

Yes it does.

Fing is an essential tool if you have a home network. So useful if you have an issue.
Just this morning I couldn’t get into Roon. Then couldn’t get to Nas either. So opened Fing and NAS was not discovered, checked it was on and running upstairs which led me to Re Boot the switch.
Result, all up and running again.

If you have a decent router with proper web interface you dont need fing but can control everything from there.

NB: Feeling sorry for @Kevin_Harrison as I went thru quite a few troubles with that NUC setup…

2 Likes

That’s another way to do it. Fing is free

In your case I would start with the basics of troubleshooting.

First I would count my blessings one by one: your BIOS is working and you had been able to install ROCK once and it had operated while showing a wrong operating drive.

Then I would affix a screen to the HDMI port of the NUCK and having done this, I would enter the BIOS by using the keyboard key (read the online? manual of your NUC) directly after starting the NUC.

In the BIOS I would check the status of both drives, to notice which drives are bootable and what is the booting order of both drives. The BIOS may well show that both drives are bootable and the first bootable drive is still 1tb drive without Operating system: in that case your NUC will wait endless for ROCK to start. If so: change the boot-order of both drives. In case ROCK works fine: happy/lucky you.

If this doesn’t work, I would consider a probing tool. In this case a bootable USB stick containing Ubuntu or another Linux version (there are many sources on internet to make one). With this USB-stick in an USB-port of the NUC and changing the boot-order in the BIOS to USB-first, I would restart the NUC. Ubuntu will start from the USB-stick and I would be able to see the content of both internal drives.

If ROCK is installed on 128 MB drive and this drive is not bootable, I would look how to make this internal drive bootable on internet. If you have succeeded making the 128 MB drive bootable and ROCK is still on this drive, I would shut down the NUC, remove the USB stick and restart the NUC and immediately enter the BIOS to change the boot-order to the 128 MB drive first. Restart the NUC and if ROCK starts correctly, you will be relieved.

If not, I would start considering to fully reformat both drives and start anew.

I would follow this basic troubleshooting order in your case.

1 Like

Thanks for that, it’s bloody horrible sorting out. Have done numerous it projects here and work, but this is something else.

I have security software etc and the Rock wasn’t showing anywhere.