No Audio Device Found, redux

I am a lifer with my system at home and very happy with Roon.

I recently purchased a one year membership (for some reason, a trial membership was not possible) for my office system. I have frequently gotten this error message only to have it disappear when I tap the mouse connected to my laptop (a HP bs1xx with i7-855OU CPU).

I reviewed other support cases and did set my firewall to accept roon and raat through the firewall, for both public and private settings (in Windows 10).

My laptop is connected to a Yamaha TSR 5790 via HDMI and to a Netgear PS 2100 storage device.

The “No Audio Device Found” message occurs several times a day but usually only after several hours of Roon Radio play.

I am also interested in any suggestions about how to optimize the signal going through this system to speakers.

Hi @John_Roberts ----- Thank you for the report and sharing this observation you have made with us. The feedback and insight are both very appreciated!

Moving forward, to help aide in our understanding of this behavior you are experiencing with the TSR 5790 may I very kindly ask you to please provide the following:

  • Please expand on description of your current setup using this link as a guide.

  • If you have any other active audio zones besides the TSR 5790 do they display the same behavior?

  • While this behavior appears to be intermittent (i.e “occurs several times a day but usually only after several hours…”) are you noticing any patterns here? From the sound of it, it seems like you are noticing this when the radio function kicks in. Does the same occur if you do not allow “radio” start and say just queue up a handful of albums?

  • While it may seem a touch elementary, since noticing this behavior have you tried rebooting not only the core machine but also the endpoint as well?


“I am also interested in any suggestions about how to optimize the signal going through this system to speakers.”

I have a posted a few articles below from our Knowledge Base that should help with this :sunglasses:

Knowledge Base: Sound Quality

Knowledge Base: Signal path


Sorry about the delayed response.

I am using a Roon 1.5 (build 323, 64 bit) housed on my HP 15-bs194od Laptop (8th Gen Intel® Core™ i7, 12GB Memory, 1TB Hard Drive, Windows® 10 Home). My music is stored on a Western Digital PR2100 and connected via network to my laptop. My laptop is connected to the Yamaha TSR 5790 via HDMI (Audioquest Cinnamon) cable. The laptop is used only for the Roon core.

There are no other zones that I use.

I am using a Netgear WNDR 4500 Router. I just now updated the firmware.

I am glad to start at “a touch elementary” point. I have done multiple re-boots of the computer, Roon, and the WD PR2100. I also switched out and upgraded all of the cabling.

I am “keeping an eye on” the Radio function coinciding with the issue. Although this function is usually on at the time it occurs, it also seems to be on when it doesn’t occur. I don’t think it has happened when the system is playing something I selected.

On a more encouraging note, it seems that it happens once nearly every day but rarely more than twice. This might be a bit less often than when I initially contacted you.

Thanks for any suggestions you provide.


6/13 update. The No Audio Device issue continues. This time, I notice that Radio was not engaged. I had set the system to shuffle between tunes for a specific performer.

No apologies necessary @John_Roberts, it’s good to hear from you. Hope all has been well!

I would like to try and further isolate some variables here a little bit and as such would kindly like to have you confirm what the experience is like if you play directly out of the internal speakers of the HP laptop. Are you presented with the same error message or does the zone remain stable during the listening session as expected?


Thanks for your understanding. Unfortunately sometimes life interferes with music.

I can try that tonight.

I will let you know how that works.


1 Like

I have tried this out over three nights.

I have tried it with three zones – two of which play through the laptop.

The morning after the first night, none of the zones were playing. However I am not certain that I left with all of them playing.

The morning after the second night (after making sure three zones were playing), none of the zones were playing in the morning.

The morning after the third night (again, after making sure three zones were playing), the only zone playing was to one playing through my receiver (which was set on inaudibly low volume).

There has been no indication of any power outage and no one else has had access to the equipment.

Does this give you any idea of what is going on?


Hi @John_Roberts — Thank you for the follow up and sharing the observations you made while running the proposed troubleshooting exercise. The continued insight is greatly appreciated!

Continuing forward, may I kindly ask you to verify for me which zones were used during your testing? My assumption is that one of the zones was the TSR 5790, which by the sound of it did not display the issue after the “third night” (“the only zone playing was to one playing through my receiver”), is this indeed the case?

Furthermore, being as you are seeing this issue occur on more than one zone my sense is that there is something more general occurring with your setup. As such I would like to enable diagnostics on your account so our techs can have a closer look into this behavior. However, before I enable this feature may I kindly ask you for the following:

Focusing on the TSR 5790 zone only

  • Please reproduce the issue and note the time of day when you are presented with the “No Audio Device Found” message.


The zones I have connected to the laptop are: (1) System Output (which plays through the TSR 5790), (2) Intel ® Display Audio/Wasapi (which also plays through the TSR 5790 through the same HDMI is the previous zone), (3) JRiver ASIO (which doesn’t work – when I try it, I get a “Transport: Failed To Initiate Audio Device” error message), and (4) Realtek High Definition Audio (which plays through the computer).

I also have an Airplay connection to the TSR 5790 which I do not use and did not run during the troubleshooting exercise.

In the troubleshooting exercise, Roon indicated that zones 1, 2, and 4 were playing music (the volume was turned down on the laptop and the TSR 5790).

When I initially contacted you, I was using Zone 2 with the TSR exclusively. Since switching to Zone 1 (about a week ago), it appears that the error has reduced in frequency.

I will stick with zone 1 (unless you suggest otherwise) and make note of when the “No Audio Device Found” message occurs.

1 Like

Here is an update to this issue:

Since switching to System Output, there has only been one disruption (in close to a week), despite continuously playing it. The disruption was likely due to a Windows update. Now I am getting messages from Roon that the back-up has not been working because Roon has not been shut off (which is a good thing, at least for now).

For reasons I cannot explain, it is more stable with System Output than with the other 3 zones.

Any ideas about what to check on that (especially for Zone 3)?


Hi @John_Roberts ----- Thank you for the follow up and more importantly thank you for your patience here. Both are greatly appreciated! A few things moving forward…

I have enabled the mentioned diagnostics on your account so our techs can have a closer look into this behavior. What this action will do is the next time Roon is active on your core machine (i.e HP 15-bs194od Laptop) a diagnostics report will automatically be generated/uploaded to our server. I will be sure to notify you when it arrives so you know that we have it :+1:

While I wait for the report to arrive can you please verify that no other applications are running at the same time as Roon on the core machine? I want to be certain that nothing is interfering with the audio drivers. Also in regard to “zone 3” (i.e JRiver ASIO), I have seen reports from other users on the community site who have been able to get this configuration to work in their setup, so while I have never worked with this setup before personally I know that it is possible. I saw you had raised this question in another thread, where you ever able to perform the test proposed by Noris? Just curious as to what the outcome was.


Hi @John_Roberts ----- Just touching base to let you know that I received the mentioned diagnostics from your core machine which have since been attached to your ticket for review by our tech team.

Once the team has completed their analysis I will be sure to share their thoughts/findings with your asap. Your patience during this process is very appreciated!


Hi @John_Roberts ---- Thank you for your patience here while our team has been reviewing the diagnostics report we received from your system. Very appreciated!

Our tech team has updated your ticket and have passed it back to me with some feedback. I had noted in your ticket that since switching to “system output” the number of “disruptions” had significantly decreased and as such the team has asked if you could please confirm that during your troubleshooting you had tried testing with a different HDMI cable?


Eric –

thanks for looking at this in more depth.

It is a laptop that is dedicated to Roon. Sometimes JRiver is running, but only rarely.

Hi @John_Roberts ----- Thank you for reaching out to me, appreciated!

Just wanted to see if you have been able to confirm the above, thanks!

“Our tech team has updated your ticket and have passed it back to me with some feedback. I had noted in your ticket that since switching to “system output” the number of “disruptions” had significantly decreased and as such the team has asked if you could please confirm that during your troubleshooting you had tried testing with a different HDMI cable?”


Eric –

I have been trying a “generic” HDMI cable for the past week or so and there may have been a few more disruptions. If there have been more, there have been only a few. Previously, I used yet another HDMI (which had a lot more drop-offs, but that was also before I started using System Output).

I switched back to the Audioquest Cinnamon HDMI this morning.

At this point, the cut-outs with “system output” seem to mostly occur when I turn the receiver volume down to mute (which I do when I leave). When I return (often 10 hours later) and turn up the receiver volume, I find that the laptop is “sleeping” and Roon is paused (which was not done by me). I am surprised that this happens since I leave Roon playing, usually in shuffle or radio mode (it doesn’t seem to make any difference) and do not do anything with the Roon volume output. At its worst, it is a little annoying. However, is it possible to set it up so that when I turn up the volume (on the receiver), Roon starts playing.

In addition to the above, I have re-checked the power settings on the laptop. I discovered an “advanced power” setting (that I had not seen before) that shuts off the hard drive. It was set for 15 minutes and I reset it for 15000 minutes. I am going to let this run for a while to see if it improves the number of cut-outs.

I cannot help but wonder if what I have been wrestling with is a hard drive shut-down issue which is disrupting Roon. Since I don’t use the laptop for anything else, it makes some sense.

If this new “experiment” with the advanced power setting is successful, I will try the other zones and see if there are any improvements in cut-outs.

Thank you for the update and feedback @John_Roberts, very appreciated!

It’s important to remember that in order for Roon to run the device hosting the core must be in an active state and not in an idle/sleeping state. How have things held up since making the mentioned adjustment to your power settings?


Eric –

It looks like System Output is stable. No issues in the past week.

I do not have resolution for the JRiver issue but will go back to it now that I have stabilized Roon. Interestingly, I am unable to use JRiver, HQPlayer, or Foobar2000 to play through Roon. Foobar2000 is not recognized by Roon and HQPlayer results in “Transport: Unable to Connect” error message.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.