No audio devices found NUC - was working great


I have been enjoying Roon on my NUC for several weeks and it has been working great. Suddenly, I get the message “No Audio Devices Found”. I have a NUC7i7BNH, 128 GB RAM SSD and 2TB HDD. I am running Roon OS Build 158, Roon Server Software 1.5 build 323… I have a wired Ethernet connection, and my Wi-Fi system sees the ROCK. I tried rebooting modem and switch, unplugging and replugging Ethernet. I normally run with wireless off, but tried turning it on - and no change. When I connect to the NUC ROCK the OS, database,server software and internal storage all read back as OK. I can move around in the music storage folders and all seems OK. I have rebooted, cold booted ad nauseum. As a Hail Mary I reinstalled the ROON OS, and the problem still exists. When I go back to my original install on my Win10machine, all is OK - all of the audio devices are there. Going back to My NUC I still have No Audio Devices found. I have tried going through the existing threads but none I have found reported this problem on the NUC.

Thanks in advance for any and all help.

Cheers, Arthur

Adding @support so they get notified.

Hi @Arthur_Moseley — Thank you for your report!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating. You mention that you are using a switch - Is there any chance it is a managed switch? Can you confirm that the NUC is on the same subnet/in same the IP Range?

When I go back to my original install on my Win10machine, all is OK - all of the audio devices are there.

Is there any difference in the networking setup for the Windows machine? Is it connected to the switch as well? Are you using WiFi?


HI Dylan,

Thanks in advance

Describe Your Setup
Tell us about your setup when reporting an issue. If you’re already running Roon (or trying to run Roon and having an issue), be sure to let us know:

what version of Roon you are running (Settings > About; If you’re running Windows, please let us know whether you’re running 32bit or 64 bit)
  • NUC7i7BNH; 128GB SSD, 8 GB RAM, 2TB HDD,

  • ROON OS Build 158

  • Roon Server Software 1.5 Build 323

  • Music Stored on 2TB HDD in NUC - 434 GB Apple Lossless files

  • Tidal HiFi Subscription

  • 200Mbps + Internet connection

  • Arris Surfboard SB6141 Cable modem connected to Googl Wi-Fi

  • Google Wi-Fi wired connection to Netgear GS608v4 Gigabit 8 Port Switch

  • Wired ethernet to NUC from Netgear switch

  • 2 additional Google WiFi Mesh Points

  • Google WiFi has my NUC displayed as a wired ethernet connection - correct MAC address

  • Ethernet on NUC DHCP

  • System was working with WiFi Disconnected

  • I can connect via wireless or wired to Google WiFi Mesh network

  • in either case “No Audio Devices Found”

  • was working great - ever since stable build of Roon Server software 1.5 came out, all was great

  • do not leave NUC runing if I am going to be away for several days

  • when I turned back on one day “No Audio Devices Found”

  • When I connect to the NUC ROCK the OS via the web (192.168.blah.blah), database,server software and internal storage all read back as OK

  • I can restart from the 192 address - NUC restarts, still No Audio Devices Found

  • when I switch back to my original Win10 Roon Installation (custom high end PC set up as VR workstation), I see all of my Audio Devices

  • Win 10 system also ethernet wired connection to Netgear GB switch

  • when I switch back to NUC, No Audio Devices Available

  • from my Win 10 OC, connecting to ROON via NUC, it does not see any music available: 0 albums, 0 tracks, 0 artists

  • via 192 link I see 98% of 114 GB available and 75% of m2TB HDD alvailable, both read "OK

  • when I try to choose Music storage folder in ROON, under \ROCK\Data I get an “Error Reading Folder”

  • Same error from iPhone X or Win10 connected to NUC

  • it is as in the NUC does not see any folders under \ROCK

  • my settings has my storage location as \ROCK\Data\Storage\InternalStorage\iTunes\iTunes Music

  • when I try to "Browse to “Edit Storage Location” I get the “Error Reading Folder, Not Found”

  • it is as if the NUC cannot access HDD, but it reads as “OK” when I connect via web browser via 192.blah.blah

  • When I try to “Change Import Settings” in Roon, I get the ROON icon equivalenet of the never ending spinning wheel

  • if I go to “Scheduked Backups”, I cannot force a backup to \ROON\Data\RoonBkup\RoonBackups

  • get error message /Backup Directory not available

  • Cold booted NUC (again)

  • now see \ROCK\Data subdirectories

  • I see the Apple Lossless Files

  • when I go to “Audio” in NUC Settings, it says Networked - these devices have been found on your network, but nothing is listed

  • still “No Audio Devices”

Should I swipe the NUC and start over? I am at a loss



What operating system you are running (Windows 7; OSX 10.9; etc)
Basic information about the device you’re using (MacBook Pro 2011 w 4gb of RAM; HP Envy laptop w i7; etc).
Describe where your music is stored – this includes hard drive description and interface type (USB, Firewire, etc. If you are using a NAS or any other kind of network storage, be sure to include the information requested in the Network section below)
Let us know your collection size (approximate number of tracks)

Describe The Issue
(if you’re having a specific issue or crash)

Feel free to ask general questions about Roon, but if you’re having a crash or some other specific issue, let us know when it happens. This could be “every time I start the app”, or “every time I click a certain button”, but the more information you provide, the better.

If you’re having problems with audio, let us know what you’re using and what you’ve tried. If your DAC is having issues, let us know what model it is, and whether you’re having issues playing out of the speakers on your laptop.

Thank you for the detailed reply, @Arthur_Moseley.

On the switch, I would check the settings and make sure that Jumbo Frames is not enabled. I would also recommend enabling flow control on the switch if it is an option, as we have seen that settings resolve a number of issues for other users in the past. Since the Windows 10 Core works with the switch I think you should be fine, but I just wanted to point out that those settings can help.

when I try to choose Music storage folder in ROON, under \ROCK\Data I get an “Error Reading Folder”

Does this happen frequently, or was this the first time this has happened?

For next steps, I recommend the following:

  • Can you give me some information about your audio devices? How are they connected (WiFi, Ethernet, USB, etc)? Can you share a screenshot of Settings > Audio in Roon?

  • I know you mentioned you rebooted your NUC, but have you also tried rebooting your networking hardware and audio devices?

  • Is there any antivirus or firewall active on the Core machine? If so, try disabling them.