"No audio devices found" when Mac display dark (darkwake, Big Sur, WoL)

I’m running Roon 1.8 on my iMac, which is running MacOS Big Sur. I have Roon Remote on my iPhone.

When my iMac is asleep, Roon Remote can’t find the core, and the Roon Remote screen goes pretty much blank, which seems normal.

If I then use a third-party app to send a magic packet/wake on Lan to the iMac, the iMac wakes up and Roon Remote finds the core and displays the normal screen. However, under these conditions, the iMac screen stays dark, which causes Roon Remote to say “No audio devices found.” If I (get out of bed, walk to the room where the computer is, and) tap a key on the iMac keyboard, the iMac screen turns on and Roon Remote finds the audio devices and all is well.

My understanding is that this iMac sleep behavior, where the system wakes from sleep but leaves the display off, is controlled by this system file:

/Library/Preferences/SystemConfiguration/com.apple.Boot.plist

and that making part of this file read as follows would solve the problem:

	         <key>Kernel Flags</key>
            <string>darkwake=0</string>

However, I also find this nugget of information about Big Sur, which I think comes from Apple:

The system volume is now read-only so you should seek to avoid modifying system files.

So, it appears that I can’t alter the com.apple.Boot.plist file to turn off darkwake. (I did try and got a permissions error.)

I could use a third-party app to prevent the iMac from ever sleeping, but that doesn’t seem very elegant. Or perhaps I could take drastic actions to allow me to write to that file, but that’s even less appealing.

The one thing I don’t understand is why having the display dark prevents Roon from finding the audio devices.

I don’t know that this is really Roon’s problem, but who knows, maybe someone knows of a solution (that I’ll like :slight_smile: )

Audio device is Allo Signature sound card on Raspberry Pi running dietpi, on Ethernet. Another audio device is a Dragonfly Red in a USB port on the iMac. Roon 1.8 on iMac 27-inch 2017 running Big Sur, on Ethernet. Router by eero, with a couple of unmanaged Netgear Ethernet switches in the network.

1 Like

I have just put Roon Core on a new man Mini (M1) running Big Sur and have exactly the same problem. What a bind. Did you ever find a solution?

Sorry, I haven’t pursued this or resolved it.

I’ve spent a couple of evenings looking into this and can’t find a solution either. There are plenty of ways to add a script that will run when the Mac wakes normally, i.e. as a consequence of user activity, but none of the scripts will execute following a Wake On Lan. It’s quite annoying.

I just stopped my M1 Mac Mini going to sleep and this seems to work. However, when running Roon server on a Windows machine (the version without any remote control features that runs on its own in the system tray) the PC sleeping isn’t an issue. Is there such a version for the mac?

My apologies, but I’m not sure what you’re asking. Could you clarify?

Sorry, yes. When installing Roon on a Windows machine, you have the option to install Roon server only. This just sits in the system tray in windows and is ‘headless’. I think that’s the term. You can’t use it to browse music, adjust settings etc. All that’s done using another device as a Roon remote. When the windows machine is sleeping there’s just a small delay while it wakes and it works flawlessly. I was wondering if there is such an install option for the Mac?

On Roon’s download page they do list a MacOS version under “Roon Server”. It says that it does not include the Roon Interface App, just like the Windows version. I don’t know if it will solve your issue, but it may be something to try. Roon Software Downloads - PC, Mac, Linux, Android & iOS | Get it Now

Great! I feel so dumb. It’s there. I’m not sure how I missed it. When I installed Roon on my new M1 Mac Mini, for some reason I thought it wasn’t an option. Thanks for forcing me to look again properly.

1 Like

I’ve encountered a similar issue and it’s pretty recent and for me the solution was to install the app “amphetamine” from the App Store. It seems to prevent this problem. It’s a free app. It keeps the Mac awake. I have it set to automatically start at login but for whatever reason it was not running after I rebooted the computer recently and I was confounded that my audio zones were not being detected.

This seems to help.

EDIT: you can also configure amphetamine to automatically start up when roon or roon server starts up

I have a solution, but it requires two separate apps so is not ideal. First, use something like Fing to wake your mac then use Remote for Mac to wake the screen. You’ll need to install Remote for Mac on your iMac as well as your phone, but I can confirm that it does work.

David_Nightingale: Thank you so much! So now there are two solutions:

  1. Run the RoonServer app on the Mac instead of the Roon app. I can confirm that Roon Remote on my iPhone can contact RoonServer even when the iMac screen is dark.

  2. Issue a Wake on Lan packet from Fing or RemoteBoot or whatever app on the iPhone, and then use the app “TV Remote” on the iPhone to contact the app “Remote for Mac” on the Mac, which causes the screen to wake up. I can confirm that this also works.

To save confusion for others, I will here state that these last two apps are by one Evgeny Cherpak, who has chosen to arrange things thus:

The iPhone app is called:

  • “TV Remote” in the iPhone app store
  • “Remote•Pro” on the iPhone screen

The companion Mac app is called:

  • “TV Remote” in the Mac app store
  • “TV Remote Control” on the blurb in the app store
  • “Remote for Mac” on the downloaded pkg file and in the Applications folder of the Mac

This problem is solved!