No audio via RoPieeeXL / RPi 4 endpoint with USB DAC

Hi, I’ve set up a RPi4b end point using RoPieeeXL. I currently have a USB Headphone DAC connected to the Pi (Optoma uDAC3).

The DAC works perfectly when connected via USB to my Macbook Pro.

The DAC shows up in Roon as both an Airplay and Roon endpoint, so all good there.

It also shows up in Spotify and Airplay on my iOS / iPadOS devices.

When I play a track using Roon I am getting no audio from the DAC. The volume in Roon says “Volume control is fixed”. I have changed this within Roon to all the available options (Fixed, DSP, Device) and I get the same outcome, track is playing but no audio. Sometimes it starts to skip through the tracks then just stops).

In RoPieee I have Audio USB selected. Also under Volume control in UPnP/DLNA and Shairport-Sync I have Software selected.

Would really like to use RPi as Airplay and Roon endpoint to save some cash on buying Roon Ready devices.

I tried Volumio too and that gave me the same result.

Hope there is something I can try (without buying a new DAC if possible). I have tried to connect the RCA out from the DAC into an amp, same thing, and also into a pair of active speakers, again same result: Roon/Spotify all show like they are playing the track but I get no sound.

The only way I can get audio is when using Volumio and selecting the headphone out of the RPi then plugging my headphones into that which defeats the purpose of having the DAC!

I have tried the Force Volume setting in the RoPieee interface and that did nothing.

Re-started my Roon core, RPi4, tried using wired ethernet and wifi, re-flashed, all give me the same result. No sound.

Where am I going wrong? Is it because the DAC is USB powered and is not getting enough power from the RPi? I’m using the official RPi4 power supply. If that is the case then clearly my use case is not supported which would be a bummer.

Screenshot 2021-01-26 at 14.46.21

Screenshot 2021-01-26 at 16.29.49
EDIT: I tried to connect my DragonFly Red to the USB of the RPi and magically I have audio! Did not need to change any settings. Audio works via spotify and airplay so all works as expected (apart from not being able to group Airplay speakers together, but can group Roon devices together).

So why is the Optoma DAC not playing nice with Roon/RoPieeeXL unless it is connected via a laptop/desktop? See this screenshot of it working when connected to my macbook pro.

Would appreciate any assistance. Thanks

Ok. Can you please simplify your setup. That makes it easier to figure out what’s going on.
so disable all XL services and let’s focus on Roon now.

If you have disabled the XL services can you send me feedback?

1 Like

thanks for the reply. I’m very new to Roon and RPi, when you say disable the XL services, do you mean airplay (shairport), squeezebox etc or disable the XL as an end point in Roon?

And what do you mean by feedback?


Indeed disable those services so we only have Roon left.

Feedback option you can find on the ‘advanced’ tab in the web interface.

1 Like

Great. Done.

Logs have been sent to RoPieee HQ with unique identifier 2076d97c48edc925

I don’t see in the logs that you actually send audio to it (from Roon). Is that correct? Can you provide me feedback while playing audio?

Now when I try to play audio to the uDAC3 (connected via USB to the RPi) Roon just cycles through all the tracks on the album or playlist. It’s like it’s trying to play them but then skips to the next one until it reaches the end and then just stops.

The feedback whilst this is happening is:



Logs flooded with USB error messages.

View things: you’re trying to play content to the device which is does not support. So again, I suggest to first figure things out with the bare minimal content: 44.1k, 16 bits, no MQA and see if this works properly.

I have set:

Max Sample Rate (PCM) upto 48KHz
Max Bits Per Sample to 16
Enable MQA decoder is set to no
MQA Capabilities is No MQA Support

Now the in Roon when sending music to the device it looks like it is playing but again there is no sound from either the headphone or RCA outputs on the DAC.

The feedback when this is happening is:


Ok. But at least this content does not result in error messages.

Can you now force the volume level of the DAC? You can find that int he web interface.

So enable ‘force volume’ and set it to 100%.

Force volume set to 100%, same result. Shows track is playing but no sound.

Feedback: 4b95a6832674616a

Does that mean no sound on both RCA and headphones out?

yes exactly.

Has there been any update to this? I’m facing the same problem. I’m running RoPieeeXL 2023.09 (1118), connected a USB-A to C adapter to Raspberry pi and attached my Astell&Kern PEE51 USB-C headphone DAC to it and have RCA cables running from the DAC to my Yamaha Aventage RX-A4A. No sound through this output. Roon however recognises the device and shows music playing through the DAC. What could be the problem?

So, I’m no expert, but I had a similar problem using Raspberry PI OS with Plexamp and Mopidy running. It turned out that my DAC had throughout issues when connected to the USB3 port of my Pi4. When I randomly plugged it into a USB2 port, everything was smooth. Since then, using Ropieee, it’s remained plugged into USB2 and all has been well. This is all very anecdotal, so YMMV.

1 Like

I tried that but that was not the problem. Turns out it was a lapse on my part. The audio input I had connected my DAC to in the AVR was disabled in the display and hence I wasn’t able to switch to that input. I played around in the settings and enabled the input and then it worked like a charm,

1 Like