No local audio device found [Solved; Firewall]

Hello @support,

I am running the latest version of Roon 1.2 64bit on a Windows 10 x64 machine (i3, 4gigs of memory) while the core is running on another Windows 10 x64 computer.

I recently upgraded to Windows 10 on the machine I am having problems with. Here is my issue.

When I open Roon I have no local audio devices listed. If I go into the Audio tab, I only see the audio zones that are installed on the core machine. If I hit refresh it flashes for a microsecond but still does not list any local sound sources. I am using a USB DAC that works fine with Windows and other programs and there is an installed soundcard as well. Neither of these show up in Connected to PC devices…

I tried uninstalling and then re-installing Roon which had no effect.

Any ideas?


Just wanted to say I’m having the exact same problem, nothing for me has worked.

Hey James,

Are you running windows 10 as well? Was it an upgrade? Everything was running fine on windows 7…

@James_Lock Hey, have you tried disabling your firewall completely? I turned off the firewall on the remote computer (the one with the problem) and low and behold it works again??

@support Can you tell me what ports need to be open so that I can turn the firewall back on? Why is the firewall causing roon not to locate local devices while still connection to lan connected devices and the core?


The processes to whitelist are Roon and RAATServer and the ports they use are set out here.

I’ve not seen local audio devices vanish, but all audio has to go through the Core, which may be a factor in why this is occurring.

This is exactly the problem I was describing in another thread… Turning off the firewall completely on the remote system did not fix the problem. I have opened up the Roon and RAATServer ports… I can only play to the audio devices that are on the Core directly from the remote computer.

Thanks for any help.


Have you tried to uninstall and then re-install the local audio drivers?

@Mike_Dubois I tried disabling and then re-enabaling audio components at the system level and this had no effect. Sound was working fine everywhere except for roon. For me this didn’t seem like a system sound issue but some sort of connection issue.

As soon as I disabled the firewall on my remote system, all system output devices instantly reappeared. If I turn the firewall back on they’re gone again. I’ll try setting up firewall rules for roon and see if that allows firewall use and roon use at the same time. For now, I have just disabled the firewall all together. I don’t really need it anyway, but don’t like the system nagging me about turning it back on…


Hi @Andrew_L ----- Thank you for the report and my apologies for the troubles here. I will say that you are on the right path here :sunglasses:

Moving forward, you will want to create firewall exceptions for Roon/RAATServer. After which you should restart the application and confirm that the audio devices can be identified by the software.


@Eric Thanks Eric, I’m good to go. I found the problem. I added the port ranges to the allowed lists and it still wasn’t working but while scanning through the programs listed in firewall settings I noticed that both roon and raats were blocked outright, so even though I had created exceptions they were still being blocked. Not sure how they managed to get blocked in the first place, but after unblocking them, low and behold it fired right up with the audio devices right where they should be.