No more ssh login?

I am running 3 roopieees, all on version 2022.08.1 (521) [stable]. They seem to work okay, but I can’t ssh into them:

ssh root@
ssh: connect to host port 22: Connection refused

I found some instructions for older roopieee versions, which had a toggle in the browser setup GUI to enable/disable ssh login. I can’t find this toggle anywhere in version 2022.08.1 (521) [stable].

Any hints on how to get ssh access working?

Don’t shoot the messenger, but if you need to get access to the underlying system, you’ll have to choose something else, because Harry decided to make Ropieee a true appliance experience only - no tinkering allowed any longer…



I was hoping to set up a custom process that monitors if music is playing, and then controls a relay to turn on/off my power amps. Would have been a nice to save some power these days.

Any means to get this done on my roopieee machines?

As I said, not on Ropieee of the current flavor!

Use Diet-Pi, Raspberry Pi OS, or anything else that runs on your Pi’s and hack away.

If using the official 7" display, choose Diet-Pi, install Roon bridge and extension manager from it’s menu, then install extension snapshots and web controller from within extension manager in Roon.

You could do this via the roon api.

I do it via home assistant - but this requires an extra Pi.

My amp doesn’t have a 12V trigger and I looked for a way to turn it on and off based on music playing.

I found a device that provides a 12V trigger based on the signal from a Toslink optical connection.
I’m able to use an unused optical output on my Pi2AES card. If you don’t have an optical output, you can use a USB port on the RPi and a USB audio to optical converter. There are many available.

Next I needed a power strip that turns on/off based on 12V trigger. This one is low cost:
It is for 120V and you’ll have to find an alternative if you need 240V.

It all worked the first time I tried it! The only problem is that there is a delay at each step, If the amp is powered off and I press the play button in Roon, it takes about 3 seconds for the amp to become fully powered, and the first few seconds of the initial track may get cut off. A remedy I found (not ideal) is that after pressing play, I wait to hear the relay click in the power strip and then I immediately press pause. I wait a couple of seconds for the amp to be fully powered, slide the play position back to zero and hit play again.

Ok, I see. Using a service running directly on the RPi to monitor the audio system would have been super easy. The methods described above are either limited to Roon (I also use Spotify or AirPlay), and the Toslink method seems a bit complicated and expensive to me.

I might just use a self-contained setup using an Arduino Nano to sense the audio signal and control a solid-state relay for the mains power of the power amp.