No music will play through Roon when using my Free Tidal account

I am using Free Trial of Roon & Free Trial of Tidal
I have used tidal on other system in my home and it works great.

Using Tidal in Roon, I can see all online music available, but cannot play any,
The error message when I try to play says:
"This track currently not available from tidal. Too many failures,stopping playback.

I have reset my router but this did not help
I disabled by firewall but this did not help.

I have no problems playing local songs saved on PC

Additionally, if I go into the roon settings - Services - Tidal - Edit - Streaming Quality
Is says "No Streaming Formats Available

MY setup is a desktop pc as the core and SMSL dac to amplifier.

Thanks for any assistance.

The free trial/ free tier of Tidal will not play within Roon.
I assume you mean you are on the free tier of Tidal?
Can you confirm the Tidal tier that you are on?

1 Like

I signed up to Tidal for a for the Hifi version, so I get full usability and flacstreaming, it’s just that I am on a trial period for a month before I pay the full amount.

Got you!
Thank you for clarification.
Ok so now it’s most likely a network issue, unfortunately Roon is a lot more demanding of network resources and bandwidth than just playing Tidal on its own outside of Roon.
Are you on a wired connection or wifi?
What sample rate are you trying to play?

Wired connection.

Sample rate would probably be Flac, what ever that is.

Additionally, if I go into the roon settings - Services - Tidal - Edit - Streaming Quality
Is says "No Streaming Formats Available

I can try and lower the bit rate in tidal and see if that helps.

This usually indicates a permissions issue on the Tidal side.

Ahh, well that’s a definite issue right there.
Roon thinks that you don’t have a valid streaming plan so it’s not going to work.
Are you sure you are signed into correct Tidal account inside of Roon?

Hmmm, ok.

I tried lowering the bitrate to the lowest available but that did not help.

Yes, I only have one Roon account

Hmm, well Roon does not think you have a valid stream account atm.
So can you try to sign out of Tidal inside of Roon, restart the Roon Core( reboot), then try signing back into Tidal inside of Roon once it’s back up and stable.

That is what I am thinking too.
I will do that and see how i go.

Thank you guys,

Let us know how you fare and we will go from there if more assistance is needed.

Thanks, I will report my findings.

I logged out of Tidal and logged in again. It said I had successfully connected to Roon.
I also logged out of Roon and back in again.

I continue to get the same error message.

Should I ask Tidal for any assistance ?
There doesn’t seem to be any limitations when i use the tidal app on its own.

All fixed.
Stupid me, I had another old Tidal account (free version) and accidentally signed in with those credentials.
Sorry to waste anybody’s time. :worried:

Everything is working well. Happy now.


Now I did ask you that earlier…lol
Only because its not the first time I have seen people do that so its not uncommon.
Well the good news is that you are enjoying Roon and Tidal
Long may it continue and welcome to Roonworld.

And no you were not wasting anybody’s time at all, thats what this community and forum is here for!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.