No native DSD anymore - converts to 352.8khz PCM

I’m using a TEAC NT-503 which is DSD256 compatible. My setup was working fine with Native DSD enabled, but for some reason that is now no longer an option and my DSD64 files are being converted to 352.8khz PCM.

I have DSD over PCM enabled, the native option is nowhere to be found anymore. No exclusive mode checkbox either. Did I unknowingly make a change to the Roon settings or to my DAC that prevents native DSD playback?

Thanks!

@support

After doing some digging here in the forums, I saw that some people experiencing a similar issue had luck with powering down the DAC, unplugging the USB cable, plugging it back in and turning the DAC back on. No such luck here. What would make the Native DSD option dissappear from Roon?

That sounds like you got a driver issue if you using Windows 10 Creator update, in this instance it may use WASPI (support only DoP) instead of the manufacturer’s ASIO driver, which support exclusively native DSD. If you experienced this, uninstall the Windows driver in system device manager, followed by the manufacturer driver then disconnect the USB-DAC. After reboot without connect the USB-DAC, you need to re-install the manufacturer driver then plug in the USB-DAC, that should works.

The proper way of sequence is always install the manufacturer driver before USB-DAC is plugged in.

1 Like

Hi, @PhillR, thanks for the report! Could you please give us the description of your setup here? What machine do you use as a Core, its operating system and other parameters.

@MusicEar, thanks for your message that you posted here, maybe it will help to solve this problem, much appreciated!


Ivan

Hi Ivan,

I use an Innuos Zenith II server/renderer which runs Roon Core on the Linux operating system. My music is stored on a Synology 1515+ NAS. I use USB out of the Zenith into the TEAC NT-503 DAC.

-Phil

Hi @PhillR ----- Thank you for following up with us and providing the requested feedback! Both are very appreciated!

Moving forward, I would definitely recommend trying to reload the drivers for the TEAC NT-503 as suggested by @MusicEar (:thumbsup:) Furthermore, may I very kindly ask you to please provide me with the following:

  • A screenshot of …

    • Your signal path leaving Roon when you make this observation.

    • The playback settings you are using with the NT-503.

  • Can you verify if you are able to upsample to DSD64 without issue, via the DSP engine?

  • Please use the instructions found here and send us over a set of your Roon and your RAATServer logs, after the issue has been reproduced.

-Eric

Hi Eric,

Here are the logs: https://www.dropbox.com/s/4ldq3apmyr4dk9l/PhillR.logs.zip?dl=0

As shown in the screenshots, there is no option to upsample to DSD64. The upsampling option maxes at 705.6khz.

According to Innuos tech support, there is no driver issue as it runs Linux. I can follow up further if you recommend it.

Thanks,
Phil

Native DSD requires support in the Linux kernel for each DAC. Did their support tell you they support Native DSD for the TEAC NT-503 specifically?

We’re going to do a bit more research and we’ll look at your logs, but I’d like to make sure we have the details correct here, since that’s the most common problem with Linux Core + Native DSD.

1 Like

Innuos tech support has told me that they have not enabled kernel support for that DAC yet and recommends that I use the DSD DoP option until that happens. Should Roon still be able to pass DSD files natively in this mode, or is the lack of DAC player support the root of the issue here?

Disable DSP Engine and retest playback of DSD64 files.

DSP now disabled. Here are signal chains from FLAC and DSD64 files:

Innuos tech support just figured out the issue. It was a setting in Roon.

When I fist set the system up, I was using the TEAC DAC’s volume control and everything worked fine. I later assigned the volume control to Roon so the wife could easily use the system from her iPhone without having to use the DAC’s remote for volume control. Switching back to “Use Device Controls” restores Native DSD playback.

Is there any way to keep both the Roon volume control & native DSD playback?

Hi @PhillR ---- Thank you for touching base with me and providing the results of your testing with the tech support team at Innous. As always, the insight is very appreciated!

Moving forward, in regard to your question:

“Is there any way to keep both the Roon volume control & native DSD playback?”

We’ve chose to put volume control in the endpoint to minimize lag/latency when changing volume. Doing a DSD soft volume control would consume a lot of resources as many endpoints in our ecosystem are not powerful enough to perform the adjustment.

Our CTO Brian goes into further details on this design choice here and here.

-Eric