No Remote Connection - iPhone, Samsung, Win Laptop

Is this Roon’s new start up page because I see it on every device I have.

So annoying!


What happens if you choose “Select a different core”?

Is your server up and running and visible on the network?

It’s hard to know what the issue is without more information. Is your core meant to be on that PC (in which case I would press “Use this PC”) or is it running on something else? You could check that your firewall isn’t restricting Roon, as Windows updates can sometimes reset your firewall settings.

Also, you may want to post this in the Support thread (with more information on your system).

Is your server up and running and visible on the network?


I want everyone to see this. Keeping remotes connected to ROON is a festering problem. As soon as I bought the Samsung tablet I realized that this is an ongoing problem.

I have been a huge advocate for ROON but keeping remotes connected to the CORE is a huge flaw. Getting a little tired of ROON blaming it on operating systems and fire walls etc. i am constantly struggling with this issue on all operating systems. I want to listen to music, not tinker with operating systems.

If you want it to be seen I’d post it to the relevant category. It’s kind of nowhere just posted in uncategorised.

Hello @Ogie, this is certainly not something you should be seeing each time. I’ve moved your thread to #support in order to get more help. To assist them could you please give some details about your setup using this link as a guide?

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hey man… thanks for the help. Sorry if it seemed if I was directing my displeasure at you.

I want this to be somewhere people will see it. Can i change the category now?

i missed all these connection issues when i was doing research for a tablet. Only after I bought the Samsung did I find all the post regarding remote problems here.

Buyer beware and do research better than I did.

Hey man… thanks for the help. Sorry if it seemed if I was directing my displeasure at you. Unintended. Just mad… again, but not at you.

No problems. I realise it can be frustrating.
My roon works all the time for my remotes on Android 6, 9 and 10, ios, iPad and windows 10.
But that doesn’t help when you are having issues, but it does show that it can work.

How can i change the category so more people will see this?

I’ve already done it for you.

However, for a next time, either when in the #support category of the forum, click the New topic button, top right, or, if you’ve already missed that, there should be a little pencil icon at the end of your thread title (right at the thread beginning). Click that and choose a category from the left hand drop down box.

Another way is via your remote: settings > support > contact Roon support

If all OK you should see Support under your thread title.

(By the way, I also have a Samsung tablet and have no problems.)

ON the screen which says "Make sure your Roon core is powered on and connected to your network. click the blue Help. Then enter the IP for your core.


That fixed it.

Thanks Rugby


Hi @Ogie,

Happy to hear that you are able to manually connect by specifying the IP. One other aspect you could try is looking for IGMP Snooping / IGMP Proxying settings on your router, those have helped with similar symptoms stemming from multicast issues in the past.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.