No Sound from DigiOne Signature Player

I purchased a DigiOne Signature Player and I cannot get to work. I am using Ropiee with a Coax connection to a Rotel RA 1570 Integrated Amp. I have re-flashed the micro SD cards a couple of times, but that has not helped. Roon can see the DigiOne and I can configure the DigiOne. Whenever I start playing something, Roon shows it streaming but no sound comes out. After a few seconds, Roons shows the device stopping.

Any ideas on what is happening?

Have you started with the simplest setup?

No DSP, no volume control, simple PCM 44.1k.

The Ropiee settings that I have been using is the simple set up that you have suggested. A few weeks ago I tried an Allo USBridge Signature with Ropiee, which worked just fine with Roon using with the same simple settings. Unfortunately, the USBridge matched poorly with my system, so I sent it back to Allo. That is why I am now trying the USBridge Signature.

I am getting the same results using Diet PI. Roon sees the DigiOne but no sound comes out. The same Coax cable works fine in the same port in amp with both my old streamer and with a CD player.

I have also tried a Pro-ject Streambox, which came with Volumio. That USB device sounded fantastic when it worked, but Roon had a hard time finding that device if either the amp or the streamer had to be re-started. Could these issues be due to issues or compatibility with the DAC in my Rotel Integrated amp?

you are using both DigiOne Signature PSU inputs with 5VDC / 3A and 5VDC / 100mA capability?

I have the Shanti power supply. The 3 amp output is plugged into the USB port on the right side of device and the 1 amp output is plugged into the left side of the device, which is above the ethernet jack.

I checked all of the connections and one was loose. Now I am getting sound but the music is skipping like crazy.


The USB-C port above the ethernet jack is for powering the RPi - there is lettering to this effect on the circuit board next to it. That needs 3A.

On the other corner, on the same level, is the USB-C port for the DigiOne Sig - labelled clean power. The 1A connection from the Shanti should power that.

In the photo the right hand near corner is the clean power socket, the one behind that the RPi 3V socket.

Is that how you have them? The photo is from the DigiOne Sig tech manual that you can download from their site

try rebooting the RPi, my DigiOne Signature sometimes skips if not booted normally after i changed something. Also try the latest Ropieee as it seems more stable to me.
Also check if internet connection and local network are fast enough to stream all sample/bit-rates. I.e. try different files locally and from internet (if applicable).