Node-roon-api-volume-control - function 'set_mute' not working

Hi @support, @danny,

Is the Github Issues section monitored? I’ve create an issue on Github couple days back.
Shell I instead push API issues here? Below is the content of the Github issue:

Function ‘set_mute’ is not working with the latest version of Roon 1.4 (306).
The ‘req’ object now contains the ‘on’/‘off’ value for mute in req.body.mode, but the function written here is trying to access it under req.body.action.

Fix can be done in two ways:
1/ fix Roon to pass the value in req.body.action
Then no update is needed on this function
2/ update the ‘set_mute’ function to use req.body.mode


Hi @StefanK,

I just fixed this on Github. I also changed the settings so that I am watching all the API issues pages. Previously I was only getting notifications for the main node-roon-api repository, so we didn’t see the Github issue.

In general we’d prefer to have issues on Github than here, but please feel free to bring them up here if we don’t respond on Github. I’m also watching the whole Roon API section on the community page, tagging support in particular shouldn’t be necessary here.

Ben Coburn

Hi @ben,

Great, thanks for the super quick action.