Not able to boot Roon ROCK after successful install

Looking for help I have tried every thread I found so far maybe I’m messing some stupid tiny detail.
Recently inherited an Intel NUC already had an OS installed on it and booted perfectly fine.

I followed the install steps and I am able to successfully install Roon but have not once been able to boot on it.

Downloaded Bios update here

Then followed all the steps for install (even did it twice) no matter what I do I am not able to boot to it.

Again I get to the “Roon install is completed” but after that I am unable to get to it. I included the screenshot of my bios settings.

Any help will be much appreciated.

Current ROCK requires UEFI but as far as I can tell it is set to Legacy (BIOS) boot. It says “No boot drive” on the UEFI tab in your 3rd screenshot, and instead the SATA boot drive is listed on the Legacy tab in the 4th screenshot. Same on the 5th screenshot, no boot drive on the left (UEFI) but instead on the right (Legacy). In the 6th screenshot, it doesn’t look like you turned off Secure Boot either.

Did you follow the ROCK installation instructions? Probably not:

Note in particular 2B. Configuring the BIOS (but don’t ignore the rest of the page either=:

1 Like

That is a SATA boot drive in a NUC8. Yuck.


Secure boot is disabled and UEFI is enabled in boot priority it just does not list any drives there…

FYI I have tried every combination of these possible other threads in forum suggested using legacy and then installing from there still no luck…

OK, but as long as you don’t have a drive in the UEFI boot priority it can’t UEFI-boot from it. Not sure why it is not there though.

@WiWavelength seems to have concerns with this …

But I don’t know. It seems to have worked with the previous OS?

Just to highlight - old ROCK installations required legacy boot, and didn’t support UEFI.

The current ones needs UEFI., and you should probably turn off legacy boot.

So it’s quite possible you will have to change the setup after a fresh install.

Yea I think that is main issue, never seeing the drive when in UEFI. If I turn off Legacy and redo the whole install with UEFI only, it shows No Bootable Device and the M2 is not listed ever in boot priority. Again every time the roon install show succesfull :person_shrugging: Wondering if updating my Bios messed up something…

Here’s what I see after doing the above in Bios

Would it be possible that the tutorial points to an old factory reset image for ROCK here?

edit: Probably not in the zip the modified date shows 2023-05-05…

The ROCK images are rarely fully up to date, it does an auto-update after installing. But it should include the latest Roon OS, which boots from UEFI (and only UEFI)

I expect you’ve tried clicking advances / using + to try and add the drive, but if not have a go.

Odd the install is happy writing to the drive, but then you can’t boot. So the drive sounds like it’s probably ok.

From those screens it doesn’t sound like there is another drive in the machine, but if there is I’d remove it for the moment.

1 Like

Yep tried all that, (no additional drive in there). at this point I might just try flashing a disk partition tool to format the existing SSD… I even tried to install Roon using the recovery option but it didnt change anything.

I think deleting any partition would be my next move too. I expect the rock install will repartition and format.

Welp I finally fixed my issue and I’m very pleased. If this would not have worked I would have probably given up… I guess my installation is sort of an edge case? The installation guide doesn’t cover this at all but if you have a used NUC with a previous install (possibly in legacy and UEFI) additional steps need to be taken.

If someone ever stumbles on this thread I did the following:

  1. Follow all the Bios steps in Roon install guide (except you won’t see your SSD in boot priority of UEFI) Also turn off legacy to be sure.
  2. Before flashing Roon Rock install do the following:
  3. Download Windows 10 Installation and flash it to your USB. (you could probably use another software but I wanted to use Diskpart).
  4. Boot on the USB
    5 Go to repair and advanced and command line (you can look for other tutorials for that)
  5. Using diskpart chose your SSD and use clean
  6. For good measure convert it to GPT but mine was already listed as such.
  7. What hapenned for me in this case was that the disk switch from free 0 to the whole disk free.
  8. I then proceeded with flashing Roon and was finally able to boot on it.

Included screenshot with steps I took with before & after. Really hope this helps someone one day!



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.