Not able to produce USB image of ROCK

I’ve tried multiple times, but Balena Etcher fails to produce a bootable USB image of the ROCK OS. The Etcher appears to successfully decompress the " . . . .img.gz" file, but then stops the flash process and comes up with this error notification: “ATTENTION: The writer process ended unexpectedly. Please try again, and if the problem persists, contact the Etcher team”. I tried with two different Windows PCs several times. I’ve previously installed ROCK as the core on a NUC and also on another NUC as an endpoint, so I’m not sure what’s really going on unless there’s a problem with Etcher or with the current ROCK image. Any ideas?

EDIT: SOLUTION (contributed by Rugby) was to use Rufus instead of Balena Etcher to flash the ROCK OS image to a USB stick. Seems that, intermittently, a lot of people have had issues with Balena Etcher.

Have you changed the media you are trying to write to?

1 Like

I’ve tried with 2 different USB sticks. They are both large USB3 sticks - does it matter if they are formatted FAT(32) vs NTFS? Maybe I need to use just a simple smaller USB2?

I’ve had problems writing ROCK using Etcher.

I think (it was awhile ago) I solved the problem by re-downloading the ROCK file. Did you try that?


1 Like

Try using Rufus instead of Etcher

1 Like

Decompress the image before using it, I always use etcher and never had an issue with rock, but I decompress to just have the .img first using 7zip on windows.

1 Like


Yes, several times, but no go.


I finally tried that late last night, but same result. Etcher prematurely terminated with the same message.


Bingo! Easy Sleazy. Rufus worked great. Balena Etcher always seems to be having issues. Anywhose, thank all of you who contributed, and, in this case, Rufus was the solution.

YAY. I’ve always used Rufus, which, by the way, was the original software to use in the first ROCK installation guide. Not sure why it changed, but, when I had weird results from Etcher, I went back to Rufus and have been golden since.

1 Like

Never ever had issues on Mac with etcher…just for the record.

1 Like

I don’t understand why etcher keeps getting recommended. The macOS version is 226.4MB big, ApplePiBaker is 8.4MB and works just as well… I really wonder what those extra 218MB are up to?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.