Not available message wrt music location

Roon core on Synology NAS, Bluesound node as endpoint.
Music stored on second NAS worked 5 days.
Roon now shows the path with comment “not available”. Bluesound sees the same NAS without problems.
What may cause such change? And what is the solution. Still in 14 day trial, but not happy.

Hi @Michael_Van_Oostrom ---- Thank you for the report and sharing your feedback with us. The insight is appreciated and I am sorry to hear of the frustrations.

Moving forward, to help us properly evaluate this behavior you are reporting, may I very kindly ask you for the following:

  • Apologies for any confusion on my part as it is a touch unclear from your report. You currently have Roon running on a Synology NAS and then have your library stored on additional NAS, is this correct? If I am indeed correct in my thinking would you please provide the following:

    • The model Synology NAS currently hosting your Roon core.
    • The make/model of NAS that is housing your musical collection (I.e “Music stored on second NAS worked 5 days”)
  • While it may seem elementary, since noticing this behavior have you tried rebooting all of your devices? This would include your core machine and any pertinent network hardware as well.

  • Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your NASs are communicating with your network/the Roon app.

  • Please provide a screenshot of your “storage” tab.


Hello Eric,

A somewhat belayed answer to your questions.
Roon core is running on a 4 months old Synology DS216+II with my music stored on a 3 year old Synology DS214 Play.

Restarting both devices worked, although it is not running flawless yet. The core lost connection twice since rebooting. With one time the music starting to break up as if it was a cd with dirt on it. Rebooting reset the sound.

Using my bluesound app, it was possible to access and play music directly so it seems clear it is an issue with the roon software.

My network consists of 2 synology NAS, Dune HD, Bluesound Node, Windows 10 PC all hard wired via Cisco router and switch. iPad provides control, wireless connection to B&W Zeppelin and Bluesound Pulse Flex.

Best Regards,

Michael van Oostrom

Thank you for touching base with me and providing the requested feedback. Both are appreciated, @Michael_Van_Oostrom.

I reviewed the specs for the device currently hosting your core (i.e the Synology DS216+ii) and the unit’s CPU is below our recommend spec for hosting RoonServer on a NAS (intel Celeron N3060). From our CTO on suggested hardware to use with Roon:

CPU cache is also really important to an app like Roon. Some CPU series (Celeron, Atom) are severely cache constrained. Once you get into Core i5 territory, there’s enough cache to go around, and as usual, a top-end CPU will confer an incremental performance benefit above that.

In light of the above, I would recommend testing with your Roon core on another device with a stronger CPU to confirm if performance improves. Let me know how the test goes and if further assistance is needed I will be glad to lend a hand.


Knowledge Base: What are the minimum requirements?