Not connecting to Arc

Roon Core Machine


Mac OS Monterey 12.6, iMac M1, 8gb ram

Networking Gear & Setup Details

ASUS RT-AC2900, wired connection to switch. From switch wired ethernet connections to Apple TV, Samsung TV, Roksan Attessa streaming amplifier (not Roon ready…yet). All with fixed IP-adress.
And, of course, Roon ROCK, also wired from same switch.

Connected Audio Devices

See above,
Apple tv connected to Samsung tv with hdmi
Samsung tv wired ethernet
Roksan Attessa streaming amplifier wired ethernet connection.
Roon ROCK wired ethernet connection via the same switch

Number of Tracks in Library

52.000 tracks

Description of Issue

Trying to connect to Roon ARC.

In order to connect to Roon from “the outside” you need to port forward your router to the Roon core’s IP-address and corresponding (internal) port. In the above case port 55002. (but you can choose between 10.000 - 65.000 for security reasons) (protocol = tcp)

See also :
and :

(security) TIP : Don’t send screenshots of the private data like your external IP (xxxx) and your Roon ARC port.

Best regards,

Something like :

1 Like

Sorry, missed that.
But you are the good guys, right?

We are, but this is a public forum and anyone or anything can read the posts

Ok I’ve tried as good as I can.
Now this message:

precisely :rofl:

Guess you should start from option 3.) and further.

Your ISP seems to be using CGNAT. In this setup, Roon ARC is unlikely going to work.

I would advise you to confirm this with your ISP, and inquire about an option to do port forwarding.

1 Like

Hey @Goran_Wall,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to check in on this thread to see if you were still running into issues getting Arc set up, and if you were able to get in touch with your ISP to double check you have a public IP address?

I’ll be on standby for your reply :pray:

I still have not succeeded in connecting to Roon Arc.
I have followed most of the suggestions above with no luck.
I guess it is something with my ASUS-router. My core has a fixed ip. I have tried to port-forward.
Or perhaps it is my iMac that is the problem.
I will attach my latest result on trying to connect.

Thank you for getting back to med.


Add images

Hey @Goran_Wall,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thank you for this. I will look into it as soon as possible and perhaps get back to you. Give me a few days.

1 Like

Sorry, I’m not a technical person
Guess I tried everything you recommended.
Now this:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

I have an incoming fiber connected to my ASUS RT-AC2900 router. My Roon core is connected via cable from the router. The cable goes from the router to a switch to wich Apple TV and my Roksan Attessa streaming amplifier also is connected (waiting for Roksan to be Roon ready)
I also have a cable-connected NAS, Synology DS218J on another LAN-port on the router.

My service provider is Bredband2 (
Geographic position is outside Stockholm, Sweden.
No Bridge Mode.

Hey @Goran_Wall,

Are you able to test connecting your core directly to your router, bypassing the switch and other things in your signal chain? This will be important to rule out any of the items above, passing in between your core and router.

Can you please share a screenshot verifying that the IP port from your router’s settings matches the port listed in your roon arc settings?

…and fixed ip

Hey @Goran_Wall,

Thank you for letting me know.

As a follow-up test, can you try changing the port number on both ends to 55000 and let me know if the issue persists?




Please take a look at below posts on this forum:

@benjamin don’t know if above is applicable for the problem of @Goran_Wall.

Kind regards,