Not finding library

My Mac Pro is working but the iPad is hung up and can’t find any libraries. I’ve tried everything I can think of. Can anyone help?

The only thing I see is a moving roon icon and the words “Looking for remote libraries . . .” It’s been that way for 24 hour and I’ve checked everything. Cannot do anything to get out of this.

Are you saying you can’t kill the Roon app, using iOS, and then restart it?

No, I was able to kill the Roon app and then restart it. But the problem remained after the new app was opened.

Hey @Kerry1give this a read over and let us know if you’re still having issues – we’ll figure out what’s going on here.

We also recently heard about some issues with the OSX firewall – if you have it enabled, it might be worth trying to switch it off and see if the issue is resolved.

OK, thanks Mike. When I get home I’ll go through these steps and let you know how it comes out.

Hey Mike. I turned the firewall off on the Mac Book Pro and restarted it, and closed and re-opened the Roon app, and then it worked fine. I had done all of that before (except turning off the firewall) and it had not fixed the problem. I assume but am not sure if the firewall was causing the remote iPad to not find the library, but I would prefer not to touch it, except I wonder if I need any firewall protection. I think there’s a button for doing a custom firewall (which I assume is less than the full firewall), but I’m not familiar with that and don’t know if the problem might come back. Do you have any suggestions? Thanks.

We’re looking into how we can improve our handling of the OSX firewall, including possibly setting exceptions for Roon in order to eliminate this kind of confusion.

Let me get an update from @jeremiah and I’ll let you know how that’s coming along, or whether we can recommend any best practices in the mean time.

Thanks Mike. Look forward to it.

Very much hit and miss for me:

  • Mac mini OS X El Capitan 10.11.2
    iPad iOS 9 latest

Connecting via Apple Basestation
DHCP from Internet router
Even when entering the IP4 address for the library I get a connection after a while - then library becomes unavailable again.