NUC 10 i5 does not find the img boot file on USB stick

Hello Roon Team and community,
I’m Martin from Germany. I apologize for my poor English.

I bought a used NUC10FNH with Intel i5. I have made all the settings according to the install guide
and I believe I have done everything correct with the img file transfer to the USB stick via Etcher.
I have tried a lot but whatever I do it always shows the message …
“reboot and select a proper boot device or insert a boot media in selected boot device and press any key”

Maybe others have seen the same thing and can help me.
Best regards, Martin






This is the content of my USB stick if a have a look at it with disk internals Linux reader.

Have you followed the BIOS configuration guide?

It’s a bit difficult to read your screenshots, but I think that you have enabled Legacy Boot - for the new versions of Roon OS, use the UEFI Boot setting instead.

As @Geoff_Coupe says, try disabling “Legacy Boot”, and enabling “UEFI Boot”:



Hi Geoff, you are a star. Thank you so much !!!
This was the problem. I was confused becauce there are tutorials in the web saying
UEFI Boot must be disabled. But this is maybe for older NUCs.
Hope I can install the codes now and can make the final settings…

Thanks again, Martin

Indeed, older versions of Roon OS (installed via the USB stick) required Legacy Boot to be set, but since later generations of Intel NUCs no longer support Legacy Boot, the new versions of Roon OS use EUFI instead.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.