NUC can’t find bootable drive

I bought a NUC8i3BEH with an 8gb memory card and 128 gb internal ssd. The exact ones on the ROCK getting started web page

When I go in to change the configuration of the bios, the instructions say to change the boot to Legacy and select the the SSD for the first boot drive, but no drives at all come up under Legacy. The Boot Drive Order parameter says “No Boot Drive”.

I saw another thread that was similar and the guy went in and reseated his ssd card in the NUC and that corrected it. I tried that but it didn’t help. Maybe I have a bad ssd card or? Thanks in advance for any help.

A little more info. Under PCI Configuration, the m.2 slot is enabled, the vendor ID is populated and there is detailed info listed for the SSD itself. So that implies to me that he sees and recognizes the SSD card.

Just install ROCK and see if it boots etc. I had the same issue but it didn’t turn out to be a problem, NUC booted and ROCK ran just fine.

Also, see this thread starting around August 20 posts.

I saw the same issue when I recently setup Rock on my NUC8. After resetting the BIOS to legacy I didn’t see the NVMe M.2 either as a bootable device. So I rebooted the NUC and went back into the BIOS. The M.2 then finally appeared as a bootable device.

Turn off SATA chipset, save and exit. Go back in and the PCIE m.2 should show in the Legacy option. It worked for me.

Thanks John. That did the trick. I was able to get past that step. But. Ran into another issue. I will do a new post for that.

Something I realized about the new Bios is that you have to make one change at a time and save. Otherwise any other options associated with the change won’t appear.

1 Like