NUC can't recognize bootable usb thumb drive when boot (NUC7PJYH)

Core Machine (Operating system/System info/Roon build number)
ROCK on a NUC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I followed the instructions here to install the ROCK to a NUC. However, when I tried to boot from the USB drive, the NUC can’t seem to recognize any bootable device (after pressing F10 in setup, the device list is empty).

I tried using different thumb drives and tried every USB port. When updating the BIOS the USB can be recognized, but not when boot. Anyone can help?


I can’t directly help, but I think you are going to be asked what generation your NUC is.

If it’s GEN10, did you see this?

My nuc version is Intel NUC7PJYH in fanless case, thanks!

I think that that particular NUC model has had the Legacy Boot function removed entirely since version 0037 of the BIOS - so you won’t be able to install ROCK on it.

It’s also not a NUC supported by Roon Labs for ROCK


You might need to try one of the audiophile Linux builds to install then add roonserver on top of that

Hello @Yuheng_Du,

This is not a supported model NUC for ROCK, you can find a list for supported models here:

Is it possible to downgrade the bios to the version before that?

I have no idea. Never tried it.

From every notice I’ve gotten when updating NUC BIOS, Intel doesn’t support falling back to a prior version or it doesn’t guarantee the results.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.