NUC won't start up after BIOS update

Can anyone help, I’m trying to update the BIOS in my i5 NUC and cannot get it to start.

I can hear it doing something but am getting the blue light flash once then stay on but no screen at all.

Can not boot to F7 either.

Probably get a quicker reply if you tagged @support (which I have just done for you) :sunglasses:


Hi @stephen_colman ---- Thank you for the report and sorry to hear of the difficulties. I have went ahead and moved your thread over to the "support section of the community site so we can address this behavior with you more directly. Thanks @xxx for flagging us down here.

Moving forward, to help aide in our understanding of this issue you are experiencing may I very kindly ask you to please briefly outline the steps you took while updating the BIOS on the mentioned NUC. I want to have a better sense as to what was performed JUST before the issue occurred.


I think i interrupted the bios update on a NUC now it won’t start at all
Now i get 1 flash of the blue light ,i then here the NUC power up.But no screen appears

Hi Stephen. What model NUC are you using? Different motherboards have different methodologies for trying to reset a failed BIOS update. Hence the question about NUC model.

However, assuming you are using a recent Intel NUC, the method on the Intel site is:

Then the Intel NUC is off, press and hold the power button for approximately 3 seconds, and then release. The Power Button menu should appear.
Press F2 to enter Intel® Visual Bios.
Press F9 to restore BIOS factory default values.
Press F10 to save and exit Intel Visual BIOS.

Another good guideline is to make sure that any machine that is undergoing a firmware update is on a UPS so if power fails in the middle, all is not lost.

1 Like

Its a 6i5SYK
Im pulling my hair out here.Only had it today and trying to install new bios and ROCK

Tried everything I get no screen at all

Been there on a NUC6i5… I had to change the security jumper on the motherboard and then follow the recovery process. Be sure your USB stick with the .bio file is plugged in before pressing the power button.

This article has more info in the “BIOS Recovery by the security jumper”

I cannot find the recovery file on the intel site ?
Is it the same as the update file ?

Yep. Same file.

Done all that, moved jumper bar etc.Done it by the book.
Now unit turns on, i can here it but no blue light.
And no screen/settings

That is a bitch.

Don’t know where you bought it or when, but Intel might take back a bricked machine.

Hi @stephen_colman — Thank you for the follow up and the continued feedback. The additional insight is very appreciated and my sincerest apologies for the delay.

Upon reading your latest posts I discussed your report with some members from our tech team and they have some concerns that the NUC itself is damaged due to the interruption mentioned during the BIOS update.

We do our best to help where and when we can but in this case if the NUC is indeed damage there isn’t much more we will be able to do here outside of what you’ve already tried to get the unit out of this state. Have you tried contacting intel regarding this behavior?