NUC7i7DNHE issues/ freezing

Hello all, I have been using the NUC7i7DNHE for two months now. Two days ago, the rock could not be reached anymore via network. It started with the webpage on the NUCs being still accessible, while the iOS apps could not find the server anymore. Rebooting was not working a few times, but finally got the ROCK back running. Until about 24h later, when it completely died. I replaced every part I can (RAM, SSDs) and reinstalling ROCK. But the NUC freezes at different stages in the setup process. The farthest I got was ‘Installing Rock’ and then the cursor eventually stops flashing within a minute or so and nothing happens anymore. Did update the BIOS of the NUC and did load a fresh ROCK image to my bootable stick. But no changes unfortunately.

So…I am new to Roon/ Rock - does that sound like a Roon issue or might the NUC be dead? Does anyone have experienced something similar?

Regards, René

Have you tried a different PSU? These can have really odd effects on computers if they are on the edge of failing.

No I haven’t. Only got the on PSU. A friend suggested that, as well. But I have no way of testing that other than ordering a replacement one.

If its still under warranty worth contacting Intel and see what they say it may need a full replacement.

Just did that. From the first replies here I gather it’s rather hardware than Roon/Rock.

After updating BIOS, do step 3 of this again even if it looks unchanged:

I did that. Treated it like a completely new NUC.

Observe whether the CPU fan works properly. If the BIOS shows a fan speed, check whether it’s normal.

If the BIOS allows you to disable TurboBoost, underclock the CPU and/or RAM, try those too.

You may verify the hardware by installing Windows or a conventional Linux distribution such as Ubuntu.

Fan works properly (and noisy), Fan speeds and temperatures seem fine. I already tried booting a Ubuntu image but that crashes with some ACPI error. I hope I can get a replacement NUC7 unit from Intel as I already am testing a NUC8, as well. And while that installs ROCK fine, it crashes/ freezes when no screen is attached…running out of options here :slight_smile:

Try using a different USB stick. Even better, download the image a second time and try it with a different USB stick.

Did that, too. Three USB sticks, three downloads.

Post the ACPI error log.

Make sure the BIOS settings are not using Windows UEFI, and try the different settings for CSM - basically anything UEFI should be avoided I guess.

I just tried disabling everything I could find regarding TurboBoost settings - and that did actually work. Though I am not really happy to buy a new i7 and then disable the performance settings. And the NUC worked fine with the settings turned on for two months before. Not really sure what to do now. Seems like its only a temporary thing and the NUC will freeze again.

The Intel support told me to dust off the cpu fan. I bought a compressed air can and did that. But with no effect. Did not think so either. The device is almost new and we neither have carpet nor any animals here. And the QNAP next to the NUC has been running fine for a year, as has the Synology before without any dust issues.

I can think of three possibilities:

  1. Thermal problem. It occurred with i7 NUC before, so I think Intel support gave a sensible suggestion. It is possible to remove the original thermal pad and replace it by better thermal paste to achieve better cooling, but this is not easy.
  2. Every CPU chip is different, and yours require a little more voltage. This is well discussed in any overclocking guide. I do not recommend doing this for normal users though. A higher voltage decreases the life and making it too high will kill the CPU immediately.
  3. Just mentioned for completeness sake, and I don’t think this is likely - power supply problem

Try re-seating the heatsink. Might as well reapply the thermal compound, too. Watch a YouTube vid if unsure how to do this.