Nucleus Plus no longer detected on network

Roon Core Machine

Nucleus Plus

Networking Gear & Setup Details

Netgear Nighthawk AC1900

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi guys,
I don’t think my Nucleus Plus is doing well :frowning: I have been enjoying the nucleus for about 16 months with no issues. This past week the nucleus seemed to have dropped off my network for no apparent reason, never to return. The nucleus is currently not reachable via the Roon web interface nor does not show up any more on the list of devices connected via the Nighthawks web interface. The nucleus is directly plugged in to my Netgear nighthawk ac1900 modem.

While troubleshooting this, I have restarted the nucleus SEVERAL times, unplugged the power cord, even tried a different ethernet wire and reset the Nighthawk modem three times without any change. All other devices on the network have no issues. I also tried to connect a monitor via both A and B HDMI ports and have gotten no response at all from the nucleus (shows no input on monitor). Even tried a different HDMI cord…

The nucleus does power on (white power light comes on) and the Ethernet port flickers green to show it has a live connection (as normal) but the nucleus is never found and unreachable. I am at a loss as to what to try next, any suggestions would be greatly appreciated.


@Ja_Roon, sorry to hear about your issues with your Nucleus Plus. Is it possible to connect an HDMI cable to your Nucleus and either a monitor or TV and take a photo of what is shown on the screen?

Sure, the lackluster response I get from my monitor is this …
I have tried other inputs on the monitor as well (same result)

Thank you @Ja_Roon, it does appear your Nucleus Plus may have a hardware issue. Did you purchase it from a dealer or from Roon direct? If from a dealer, you should contact them directly, and if from Roon, we can help you tag support for assistance.

1 Like

I purchased the Nucleus Plus directly from Roon. Thank you for your assistance.

1 Like

I will tag @support for you.

A post was merged into an existing topic: I have the same problem

Hi @Ja_Roon ,

Thanks for reaching out and sorry to hear about the troubles here! It sounds like we will need to RMA your Nucleus, considering there is no HDMI output. I will follow up with you via private message to gather purchase details, thanks!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.