Nucleus+ setup problems

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
QNAP TS-251 on ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
USB to Auralic Vega

Description Of Issue
I am setting up my Nucleus+for the first time. Previously I ran RoonServer off of my QNAP NAS. I made a backup on an external USB drive. I plugged this into the Nucleus+. I followed the Migration Guide. When it finished I got a screen about ‘Authorizations’. I thought I understood it to mean to disconnect my NAS, which I did.

Then Roon opened up and I had no library. I looked at my watched folder and it showed my NAS as unavailable. When I click ‘Edit’ then ‘Browse’ it doesn’t allow me to select my NAS.

How do I restore my library that will stay (for now) on my NAS?

Here’s a view of my storage setup:

And if I try and edit (then browse) the location to fix it:

You have to put the NAS address in manually. Your backup should identify your music and store any analysis but it can’t point your Nucleus to the music as it was internal to the Qnap but is external to the Nucleus.

I have tried that multiple times using the path name and the IP address, even though the migration instructions indicate “If your previous storage location was being accessed over the network, no changes should be required.”

I have the NAS and Nuc+ plugged into ports of a Netsafe GS105 switch. I seem to still be able to connect to RoonServer via my NAS (disconnect Nuc+, connect and login to NAS). I see on my NAS console that the Nucleus IP is being blocked, though I have it set to allow connections. So I’ll look into that some more. But open to suggestions…

One thing I read in the Knowledgebase is that Roon may have a problem with special characters in passwords, which I find sort of strange. I will look at that but it’s the same password I’ve been using.

Hi @rcaudio,

It looks like previously the music was stored locally on the QNAP, so you’ll need to add the folders again over the network. We have some troubleshooting information about this here in our KB.

Let’s try entering the path using the IP address, like this: smb://892.168.1.135/Music. Make sure that the appropriate Username and Password are being used here as well, and that the NAS is properly configured to allow these folders to be accessed over the network.

If your password contains a special character, definitely try changing it so that it doesn’t include this and let us know if that helps.

Hi Dylan,

I followed the FAQ to a T and couldn’t get it to work even using the IP address. I did not change the password, I didn’t get to that. I find it a little surprising that the Nuc would have problems with this.

What I finally did, and I don’t understand why, is to create a user account on my NAS for the Nuc+. Then I added a network share in Roon using those credentials and voila, it started rebuilding my library. So I’m guessing there’s some sort of security on my NAS that required this.

[Update] I let Roon run for several hours rebuilding my library. I have my playlists I created before and all my history. That a few other observations, I believe I came out intact in the end. And on first listening I am pleased with SQ. Now I have horsepower to play with DSP.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.