OpenGL 3.0 and RDP

Hi, since the Roon iOS app does not work remotely even if VPN is enabled, I would like to RDP into my home pc and run a local instance of Roon on the pc. However, Roon does not run due to the OpenGL requirement. I will note, however, that when I was simply using embedded graphics on the i7 6700k chip that Roon does run over RDP, but when I upgraded to a GTX 1080 so I can do HQPlayer CUDA offload, that it stopped working. (I’ve also tried setting the default graphics to the 6700k, but for some reason, my BIOS automatically switches it back to the GTX and so that is not an option for me).

With that as background, I notice that if Roon is already running on that PC when I RDP in, Roon will continue to work. This suggests the OpenGL check is only done at startup and OpenGL is not an absolute requirement. Would it be possible to create an option to disable that startup check?

Thank you.

The issue is with OpenGL and RDP and has been around for years before Roon was even a company, Either leave Roon up on the remote computer so you don’t have to start it or use TeamViewer. I use TeamViewer.

Will leave it open if I can remember, but an option to disable the check (since it runs fine via RDP) would be even better! As for TeamViewer, I’d rather not have so many different programs will access to my network. I use RDP for other things besides Roon.

The problem with RDP and OpenGL is between RDP, OpenGL and the NVidia video drivers. So, yes using Intel’s drivers will work, NVidia’s drivers will not. Apparently, NVidia has only bothered fixing this for the Quadro line of video cards.