OPPO UDP-203 and UDP-205 now Roon Ready

What does the icon look like in the signal path for the OPPO?

Thank you, that looks great, hopefully we can get that to work without glitches

Max rate gave the pink noise. “For Compatibility Only” is the one that works properly for me.


Ok thanks Robert. I’ll quit being a pain and let you get back to Roon’ing with your Oppo ! :notes: Happy days

1 Like

thanks for that :smiley:

I don’t do much more than upsample with the DSP. Hopefully, the more technically saavy will weigh in. I tried connecting via USB from the Oppo front panel to my Meridian headphone amp, but couldn’t get it to catch…???

Sounds great in native resolution though on HDMI, analog, and optical…

Excellent. I was only asking to test the up-sampling only to get an idea of what the network interface supports. The signal path looks groovy with the pic


Because all audio outputs are active, HDMI caps at least the UDP-203 at 176.4/192 kHz. So, Roon downsamples for compatibility.


No problem rolling flac native files 24/192 from my office SSD to the Oppo in the media room. As the firmware gets rolled out, I’m sure improvements will roll out. It’s a great start. It another Roon Ready player in my setup, (also have Sonore microRendu and Bryston BDP-1) but useful, since the TV screen with the song info is handy for background listening…

1 Like

Interested to know if Network and USB are supported at better than 24/192 or DSD64

Power of 2 upsampling works. Crossing between 44.1/48 kHz sampling rate families does not work – that results in white noise.



Does DSD64 (DoP) work over ethernet too? Should do, as it rides PCM176

No, as far as I can tell, DSD is not an option in the Device Setup or DSP Engine. DSD64 automatically is two stage downsampled to 176.4 kHz.


Interesting. Thanks for checking.

Makes sense though. I think DSD input is only supported over HDMI and can only be output over the encrypted/protected HDMI output and analogue outputs?

Unfortunately, Power of 2 produces white/pink noise for me. Are you using USB, HDMI, analog to output?

Err, I believe I set my own power of 2 rate (e.g. 96 kHz -> 192 kHz) under Custom. That worked. As I recall, the Roon Max PCM rate (Power of 2) option did not work. Perhaps because it pushes the rate above 176.4/192 kHz.


No go for me. 44.1 to 88.2 custom equals white noise. Must be another setting somewhere. Maybe in the Oppo?

Under Custom, both 44.1 kHz -> 88.2 kHz and 96 kHz -> 192 kHz work for me. Sample rate changes on the fly, though, have produced some alternately chipmunk audio or ultra slow mo audio.


And now 44.1 kHz -> 96 kHz is working. In Device Setup, I adjusted Resync Delay to 500 ms.