Overhauled Search in Roon

Sometimes Roon Search is your friend and then it’s not. Search in Roon remains very badly broken, regardless the assurances from the Roon Team that “search has now been fixed!!!”.

5 Likes

While this is absolutely true it came up for me as the first hit, in this instance.

As I said “sometimes Roon search is your friend”. Overall Roon search pretty much worthless since it’s so unpredictable.

2 Likes

Good point.

Go to Al Di Meola the artist and look under discography. It will be there.

The plot thickens.

After seeing that a few people were able to do a successful Search, I tried again and, lo and behold, the album now shows up as 2nd in the Search results, behind the selection I previously referred to.

W.T.F? I suppose one explanation is that I am going mad (one goes mad the same way one goes bankrupt; slowly at first and then suddenly all at once :slightly_smiling_face:), but I think something more Roon is happening.

Does Roon cache its Search results on their servers? If so, then the fact that several people Searched on the album as a result of my post would explain why I can now find it. That explanation might be a stretch and doesn’t explain why I couldn’t at first find it, but I can think of no other Roon Search reason.

Last night, I tried to add the album to my library. That was approximately 8 hours ago. Even tho Roon return a mesage that it was added, Roon seems to be still trying to accomplish that, with the resulting spinning icon.

Dropping that Roon iOS app and bringing it back up results in a blank screen with the message, ‘This album was not found’…

I used to have this all the time, drove me absolutely mad.

Recently I got so sick of the issue (among other things), I started changing things in my setup piece by piece to figure out what happened.

When I switched from NAS to an ssd directly connected to the core this issue was eliminated.

That issue is particularly annoying because in my experience it didn’t tell me it failed to add the album to my library. So a week later I’d discover that an album I added and liked was actually still not in my library.

Exactly. The message that an album was added shouldn’t be displayed until the album is actually added. Just another logic problem within Roon’s code that should be easy to fix if someone tried.

Thanks for the suggestion, but my music files are on a 2nd drive in my ROCK NUC.

Interesting, the other change I made was introducing a network switch but from testing it made a massive difference to latency but didn’t seem to solve this issue.

Are you using a switch?

Yeah, have been for years. I suppose it could be failing, but I really doubt it. Not sure how a failing switch could affect adding a Qobuz album to my Library, but I guess anything’s possible.

This whole SNAFU, the Search problems and not being able to add the album to the library, only occurs (so far) with this one album. I added three other albums last night without any problems.

This morning, I checked last night’s Backup result and there was no message about a corrupted Library. So, unless that logic is not working, my library would seem to be OK.

It wouldn’t, was just trying to figure out if there was something that could cause it.

Seems like it just happens for unknown reasons.

1 Like

So my post was moved to this mistitled thread. The title for this thread should be: Overhauled but Still Badly Broken Search in Roon

Additionally there needs to be a new thread about Roon not correctly adding items from Tidal and Qobuz to one’s music library.

But hey Valance is great!!! :wink:

3 Likes

The thing is that this problem will go right down a rat hole along with all the other Search problems and if there is a resolution users will never know what it was.

As far as indicating that a selection has been added to one’s Library when, in fact, it hasn’t seems like something easy to fix. Still, the solution is probably going to go on a lengthening list of Roon’s bugs to be addressed at some unspecified future time.

2 Likes

The real problem is the fact that Roon and Qobuz/Tidal are partners. One side’s programmers say “hey it’s not our code that’s the problem, it’s their code” and of course the other side says exactly the same thing. Therefore, there is a lot of finger pointing and nothing gets fixed.

Roon software knows when an album has truly been added to one’s library because the add icon stops spinning. Within that code is where the ‘added’ message should be generated.

I stand by my previous post. A lot of finger pointing and no solutions.

Yes, in general I agree with your post, but in this particular instance the fault is in Roon’s code and I hope they see fit to fix it, soon.

I find that besides network issues, the other main source of Roon problems tends to be the Roon/Qobuz/Tidal interface. And since these Roon/Qobuz/Tidal issues tend to not be quickly resolved by Roon I think finger pointing. In the tech world it’s always someone else’s code/equipment/operating system causing the trouble. I guess that’s why people love Apple.

An example search that went wrong. Was looking for the track ‘Into Dust’ by Mazzy Starr. They are not in my library, I have Tidal.

Searching first for Artist and Track:

Searching next for Artist, seems to find the wrong one:

Searching next for Track, finds what I was looking for:

@Anthony_B , it appears you’ve spelled “Mazzy Star” incorrectly in your original searches?

2 Likes