Periodically unable to connect to Roon Core - [Solved - Netgear Orbi Router issue - Solved by Enabling IGMP Proxying]

I have a Core running on a QNAP TS451+ with 8GB and an SSD for the database. I use my Samsung S8 or a Surface laptop for control. My audio goes to a Bluesound Node2 connected to an Anthem AVM60. I find that once or twice a week when I attempt to control the core, I am unable to connect to the core. I can connect directly to the QNAP using a web browser and see the core is running. If I restart the Roon application only on the QNAP, I am immediately able to connect from either the S8 or the surface laptop to the core.

My network is based on Netgear Orbi wireless router and wireless extenders and several Netgear Gig switches. The QNAP and Bluesound are wired, the S8 and Surface laptop are wireless. The wireless and wired share the same network. The QNAP is using a single Gig ethernet connection and is not configured for virtual switch or bonding. The QNAP has a fixed address assigned by the Orbi via DHCP. The Orbi acts as the DNS locally.

Core on QNAP, Control on Surface Laptop - 1.5 (build 323) stable (64bit)
Control on S8 - 1.5 (build 323) stable (32bit)
Bluesound - 2.16.9, RAAT SDK 1.1.15
Database - ~13K tracks, 1187 MB - Free space: 97 GB

Hello @Craig_Reilly,

We have previously had reports of customer experiencing issues when using wireless extenders in their network. Is it possible that you are unable to connect to QNAP when your control devices are only on the extended network? You mentioned that you have several Netgear Gig switches, are they managed or un-manged switches? There have been reports that enabling flow control in the switch can help the detection of the Roon app, more information can be found here:

Are you able to reproduce the issue or does it only seem to occur randomly? If you temporarily remove the wireless extenders from the setup, does it seem to be more stable? Please let me know when you have a chance.


The Netgear switches are gs108 and are unmanaged. The QoS DSCP and 802.1P COS support is on and not configurable. The QoS on the Orbi is also always on and not configurable. I don’t see any specific QoS options on the QNAP for marking packets. None of the devices or switches are VLAN tagging packets.

Since the connection issue is random and sporadic, I will wait for the next occurrence and check which of the three wireless devices the control is connected to. The Orbi GUI shows for each attached device what wireless channel and AP is in use.

I have caught the situation twice now, once the control laptop was connected to a satellite AP and once to the main AP/router. Is there a particular log that would help narrow the issue?

Each time a restart of the core application on the NAS immediately cleared up the issue. No problems connecting from the same laptop to the NAS using the same interfaces.

Does the Roon protocol utilize some broadcast that could be getting blocked in my network? My only firewall is the outbound port NAT on the router. No other traffic should be blocked by the transport equipment. I am not running a host based firewall on the NAS that I know of. My laptop has the stock firewall provided by Microsoft. If the laptop firewall was the issue, you would expect a control restart on the laptop to be more effective in fixing the issue than an application restart on the NAS.

1 Like

Hello @Craig_Reilly,

Thanks for your helpful insight, it is much appreciated. For your firewall to properly allow Roon communication you will need to open the ports listed in this thread here, these ports need to be allowed on all firewalls from NAS -> Core -> Switch (if managed) -> Router:

Furthermore, I have enabled Diagnostics mode on your account and what this action will do is next time your Roon Core is active, a log report will automatically be generated and uploaded to our servers for additional analysis. Upon receiving the said logs, I will create a case for you with our QA team and let you know that they have begun their investigation as to what can be causing the random disconnects. I appreciate your patience here while we take a look at what could be going wrong, but in the meantime I kindly ask for you to give the above thread a read and make sure that you have opened the required ports so that we can hopefully eliminate the firewall from the equation.


From what I can see on the windows defender firewall on my laptop, inbound TCP and UDP is allowed on any port to raatserver.exe and roonserver.exe from the private address space. I don’t see any outbound rules. I do see entries under Monitoring->Firewall similar to inbound, basically wide open to both applications.

The firewall on the NAS is set to allow all connections. Neither should be in the way. There is no other firewall than on the internet router and that should only impact internet traffic.

Hello @Craig_Reilly,

Thank you for your reply and confirming that the firewall allows those rules for Roon to connect. I have just received the report from QA regarding your case:

To answer your question about broadcast protocol, we use multicast to discover Roon clients on the network. If you restart Roon on the NAS, the core sends discovery packets to the network saying it is online and any Roon app that listens for those packets can connect. In your case, it seems that after some time the Core’s discovery packets aren’t successfully reaching the network.

Recommended Actions:
I would verify the sleep settings on the NAS, if this feature is ON I would advise to disable it to see if it resolves the issue. I would also double-check multicast related settings on all the gear to make sure multicast is enabled.

Can you please let me know if any of the recommended actions resolve the issue at hand?


On the NAS, the power schedule is disabled as is EuP Mode. I don’t see any specific parameters for ethernet power savings in the network section. If the QNAP has additional power savings running, I have not found it yet.

On my router, there is a Disable IGMP Proxying parameter. I turned this off to see if it helps but it should not have affected internal traffic. No other multicast controls are exposed.

Its been about a week and I am having no more problems reaching the core after turning off the Disable IGMP Proxy setting on the router. Connnects every time. I can’t explain how this router setting impacts traffic from my WLAN to LAN thru the router that does not go to the internet.

Hello @Craig_Reilly,

Glad to hear that disabling IGMP has been an effective solution thus far, just want to check in with you here to see if everything is still working as expected and if so I will mark this thread as solved. Thanks in advance for your reply here!


I unchecked the box “Disable IGMP Proxying”.

Disable IGMP Proxying

The IGMP Proxying function lets a LAN PC to receive the multicast traffic it is interested in from
the Internet. You can click this check box to disable the function if you do not need it.

I believe the intended effect was to enable the IGMP proxy function from the internet to the LAN side. I have no idea how this affected muticast traffic from one host to another on the LAN side but my laptop is now able to consistently find the roon server. The Netgear description does not explain that the parameter impacts LAN to WLAN traffic. You can close the issue although I don’t understand how this worked.

Hello @Craig_Reilly,

Thanks for letting us know that IGMP Proxying was the setting that caused this error. While we are not exactly sure why it affected multicast traffic either, I have forwarded your notes to our QA team who will take a closer look at this setting for the future. I’m going to go ahead and mark your case as [Solved] but if you run into any more issues just let us know!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.