Peter Gabriel's I/O - Love Can Heal

Is it my system, or was (at least) one track on the dark mix of i/o showing audible distortion on the left channel

Edit: I’ve moved these posts to a thread of their own…

Edit 2: TL:DR - use Headroom Management with Convolution Filters…


I’ll take another listen :thinking:

What media?

download from Qobuz - FLAC 96kHz 24 bit.

1 Like

Let’s see (listen) :ear:

Edit: I hear what you refer to. Like a distorted (edit: not rattle) resonance type sound ?? :person_shrugging:


which track? I have the same version…

1 Like

I thought The Court, but having listened several times I can’t hear it now.

I have the CDs and it might be intentional to sound gritty, Dark

going there now - in Arcam B&W palace…

Yup - it’s somewhat unexpected - an artefact of a 2 channel mix-down from a multi-channel master?

listened several tracks, no anomalies sofar. Which track @Geoff_Coupe ?

will have to play it through again tomorrow - I heard it yesterday and can’t remember which track it was. Definitely on the dark mix side, though

I’m going to have a good headphone session with the Dark Side tomorrow night. I’ll play the Qobuz 24/96 and CD 16/44.1 and compare to Apple Music Atmos (In-Side Mix)

the court has some rumble so to speak, but imo all intentional.

Right, I’ve now listened to the album again today and discovered some things:

  • the track in question is Love Can Heal on the dark-side mix
  • I’m playing the track to a RPi4/RoPieee connected via USB to a Quad Artera Link (preamp) > Artera Stereo (amp) > Quad ESL57 speakers
  • listening to the point from 2:51 onwards…
  • with my convolution filters switched on, I hear distinct distortion, with them disabled - no distortion!

Any ideas about what’s going on here? Something about the room’s acoustics? Needless to say, listening through my headphones or my PC’s crappy speakers don’t show anything up…

1 Like

Headroom? Convolution filters can easily clip on some material.

1 Like

But shouldn’t I get the red clipping icon in that case?

1 Like

Probably. That was my next question. (Sorry if I missed it above.)

1 Like

Um - not seeing it, but I now notice that I don’t have headroom management enabled. I’ll put that on and try again… Thanks for the suggestion.

And now I see that the clipping indicator only shows when headroom management is enabled - doh!

1 Like

Yup - headroom management needed, and more than -3dB (clipping indicator just gone red)

It needs -8dB…

Thanks, @joel !


I learn something new about Roon every day… :grinning:


Hmm. It would make a lot sense to have it always on, but then of course we’d be accused of having something “inactive” active in the signal path :man_facepalming:

Personally I think it should always be on if there’s convolution or a change in sample rate going on.