Pi4 + Ropieee XL + Topping D70s MQA - Issues with MQA playback

Hi there, not sure if this is the right forum to post this (as I am not sure its a Ropieee issue) but I am having issues with playing Tidal MQA streams through Roon.

Setup is : Pi4 4gb with RopieeeXL (Latest release version) wired ethernet in -> Topping D70s MQA Dac via USB -> XLR to power amp -> Speakers.

The issue I’m having is that the dac does not seem to lock onto the MQA stream properly, resulting in the following:

  • Pressing play can result in the playback slider advancing, but no sound

  • advancing or rewinding the playback slider stops sound, while slider continues to advance from placed position

  • Left or Right channels will sometimes not work (playback from one channel only)

  • Pausing and restarting will result in no sound, while playback slider advances

I have tried a few albums (96k MQA, 88 and 44k MQA) and have had the above issues. I have set the resynch delay to 50ms from 0 and the above issues are still occurring. There are no issues streaming CD quality FLAC. Using the Pi + Ropieee in Airplay mode results in no issues in playback with either MQA or CD FLAC files - hence my suspicion its a dac / signal issue.

D70s MQA and FLAC signal chains are listed below :

Equivalent Airplay signal chain:

I have also tested the Pi4+ Ropieee as a streamer to my Cambridge CXNv2 streamer/dac. There are no issues in MQA or FLAC playback via USB (Roon is decoder - no MQA renderer so first unfold only).

Any advice is appreciated! Thanks, Gerry

Are you connected via Wifi or LAN?

Maybe worth sending Harry @spockfish a feedback in the advanced menu on the GUI

Check whether you’re using the latest firmware for the DAC.

Disable Volume Leveling and Disable DSP Engine. If these help, your current DAC firmware is not supporting MQA rendering.

@wizardofoz Thanks - I’ll send through Ropieee to @spockfish. I am using wired.
@wklie No updates yet. I do have an email to Topping support - maybe they have discovered or other users have discovered a similar issue. I will try with a cleaner signal chain to see if it makes a difference.



@spockfish Hi Harry I sent a log to you - adfb13423081faca - to see if there is anything wrong with Ropieee configuration that is causing the issue. Appreciate any feedback.

Otherwise the problem continues with no convolution filters or volume levelling in place.


Your logs are being flooded with RoonBridge reporting buffer underrun errors and I see USB input/output errors.

I think the problem lies on the DAC side of things.

Thanks, I suspected so. GH

Hi @Gerry_Hannochko Question: I read on another forum that your MQA problem was solved by upgrading to the Topping D70s firmware 5.0. Can you confirm this? Thx!

Hi @Francois_De_Heel. I think the 5.0 is a windows driver - maybe ASIO. I use a Mac and a Linux based Pi so did not test (I might have already returned the unit by 1/28 when it was released). At the time Topping support didn’t suggest 5.0 so it might not have been out or applicable and they did not have a firmware update available.

They just released a 1.3 firmware for the D70s on April 28 that “Fixed the bug that occasionally abnormal when playing MQA.” from their webpage. Hopefully, that will fix the issue but I no longer have the unit.

Cheers, Gerry

1 Like