Pierre Boulez: Ravel - The Orchestral Works

In Roon’s metadata, tracks 7-9 are correctly listed as the Piano Concerto for the Left Hand in the Identify album dialog:

but when they are imported, they are incorrectly listed as the Piano Concerto in G minor

Hi Fazal,

It’s not very clear what you are trying to do.

  1. The discogs link is to a 1 CD version of the orchestral works.
  2. You are matching to the 3rd CD of a 3CD boxset.
  3. You only seem to have one work. That seems to be numbered 3.01, 3.02, 3.03. So that was probably ripped from the 3CD box set.
  4. From your screen shot you seem to have at least one more work from either the 1CD version or the 3CD box set or at least the album covers match.

Do you have a complete version of either the 1CD or 3CD boxset? If you number the works sequentially and add all the relevant disc numbers I think you will have a lot more luck with the import.

I know that some have the habit of splitting their albums up into separate works. Is that what you are trying to do?

I used disco.gs as Allmusic doesn’t have track listings: https://www.allmusic.com/album/ravel-the-orchestral-works-mw0001940046

When I was ripping to iTunes, I would split each composition into its own album, due to the limitations in iTunes metadata until they added work/movement (something so well hidden I was unaware of it until I used Roon, despite having used iTunes since 2001).

During identification, Roon matches the tracks to a subset of the album correctly. Whether it matches to a single disc or the 3-disc bundle is irrelevant. What ends up happening is the 3 tracks inside Roon are matched to the wrong composition, that does not match what the disc identification wizard was showing (concerto in G vs concerto in D). I tried deleting the tracks from the Nucleus, running maintenance on the library, then reimporting and reidentifying, to no avail.

The only possible conclusion it seems to me is that in some database somewhere the 3 tracks have the wrong composition ID associated with them, even if the name is correct. The disc or 3-disc set doesn’t even have a recording of the Concerto in G in it!

If you click on the little “2” counter in your screenshot you will see the other Concerto in G composition you must have. So roon thinks you have 2 of them. Once roon has made this link it can be difficult to break. The first thing I would try is setting the WORK/PART tags of your Concerto for left hand to match allmusic if you haven’t done that already. Roon is really album centric so long-term you might want to consider re-assembling your albums. If everything is split I don’t know how practical that will be.

I tried setting Work/Movement, and now it merged all three together into the Concerto in G…

It looks like the Performance/Composition munging alluded to in https://kb.roonlabs.com/Metadata_Model has decided the D major is a close enough match to G major and merged both. This sticks even if I delete all tracks from Roon, purge the library of deleted files and reimport.

OK, I found a solution. I tagged the Concerto in D sources in iTunes with the Marcel Marnat catalog number M. 82 (vs. M. 83 for the Concerto in G) and having the opus/catalog number. It looks like the munging algorithm will not molest the compositions or merge them if they have distinct Catalog Numbers.

The M. 82 catalog number is sufficiently obscure that neither of my versions had any mention of it, I had to look it up in Wikipedia.

I suspect some of the challenges are because the algorithm was trained on English descriptions and fails with French titles and conventions. This is specially acute for Ravel, where there are several variations (like the same catalog number used for the piano solo vs. orchestral arrangement).

Hi @Fazal_Majid,

Can you share a screenshot of you import settings in Settings > Library > Import Settings?

Can you also share some screenshots of the tags for these tracks so we can take a look?


As I mentioned, adding a catalog number manually fixed the issue.