Play Now screen locks - up, won’t accept any commands

Core Machine (SonicTrandporter i 7
1.7 build 528; UltraRendu 2.8 update; ultraDigital USB to S/PDIF converter; Benchmark DAC 1 HDR)

Ethernet cable connected to SonicTransporter i 7 via Netgear GS 108 gigabit switch.

Roon app on iPhone 7 to operate


Audio devices: UltraRendu connected to SonicTransporter i 7 via Ethernet cable, USB to ultraDigital, S/PDIF cable to Benchmark DAC)

After playing a TIDAL track then switching to another TIDAL track Play Now screen locks-up and time bar slides back and forth when push play, then push pause and screen locks-up
TIDAL services in settings has black circle rotating.
I correct the issue by logging out of TIDAL then logging back into TIDAL (Disable operates, but after pushing Enable Roon logo appears on screen but doesn’t ever stop) then leave Roon app, turn off WiFi on iPhone, then go back to Roon app, wait until
Lost Connection message appears, restore WiFi in iPhone settings then go back to Roon app, which restores Roon app to regular operation.

The Resync Delay in Device Set-up is set to 1500 ms because I’m using S/PDIF cable to DAC.

Hi @greg_keil,

It sounds like you’re having an issue with TIDAL logging in properly. Could you please try:

  1. Log out of TIDAL
  2. Perform a full reboot of the Core
  3. Log back into TIDAL
  4. Verify if the same issues occur

After an automatic Roon Remote update for my iPhone on April 8th or 9th the problem seemed to be solved, except the same problem occurred on April 17 again.

So on April 18th I followed your suggestion and seems to be ok now.

I’ll let you know if I have any further problems.

1 Like

The Now Playing screen locked-up again on a previously played TIDAL track this morning April 19th. Roon settings>services>TIDAL has spinning black circle.

To unlock Now Playing screen:
Log-out TIDAL
Reboot Core
Log-in TIDAL

Please let me know how to prevent the Now Playing screen from locking up.

Hi @greg_keil,

Is there any change in behavior if you try clearing out your TIDAL cache?

  • Stop RoonServer from the SonicTransporter WebUI
  • Open your SonicTransporter Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting RoonServer and verify if the issue still occurs

The sonicorbiter GUI for the Transporter has a “clear cache” button.

Is the clear cache command an easier way to accomplish the same result as your suggestion to move the server cache?

Hi @greg_keil,

I can’t say for certain what that clear cache button does, it is possible that it would clear the general SonicTransporter cache (and not the Roon-specific one). The RoonServer/Cache is the one which I hope will help to clear out.

The button is actually named “clear Roon server cache”. So that would be the cache you want cleared, correct?

Hi @greg_keil,

Yes, in that case it should be the same cache folder, so I would give it a try. I would also ensure you are on the latest release, we just updated Roon today and it contains a few changes on how our TIDAL login flow works, so please be sure that it says build 538 in Roon Settings -> About.

1 Like

An update just downloaded Version 1.7 , build 536,
“You have the latest version installed”

Is there a new build 538 that is yet to be downloaded?

Hi @greg_keil,

Yes, build 536 is the newest release, apologies that was a typo on my end.
Do let me know if this release helps with the issues.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.