Playback failed because $ could not connect to HQ Player

I want to try out HQ Player to compare SQ of it vs Roon.
My set up is:
Roon core on Dell I7/SSD–>ASUS Router–> Teac Nt-505–>Preamp

I installed HQ Player Desktop, followed setup instructions from Roon, tried both Local network and actual IP address of the Teac as input, enabled Network connection in HQ Player setup menu. disable the Audio device of Teac in Roon, when I tried to play music I got the ‘Playback failed…’ message.
Please help if you have run into similar issues. Thanks.

Is the PC you installed HQPlayer on hooked straight to dac ?

The PC is on network connected to streamer/DAC via ethernet cable.

Roon sends info to Hqplayer.PC wereHQPlayer is installed has to be connected directly to dac or you can use a naa device hooked to dac for it to work

Your TEAC doesn’t support HQP’s protocol (NAA) over it’s ethernet input.

Do you have something like a Raspberry Pi lying around? Or another similar low powered SBC?

Depending on what you have, you can burn HQP NAA OS (image) to an SD card. Then connect the SBC via USB cable to your Teac.

Then your HQP Server (Dell) should ‘see’ the SBC/Teac over the network.

You can also directly connect your HQP Server to your Teac via USB cable, for your testing purposes. If you like HQP, then you can invest in a separate low power consumption HQP NAA endpoint.

I have a Sonore microRendu which functions nicely as a HQP NAA endpoint. I also use one of these with the NAA image loaded on a USB stick. It’s recommended by Jussi:

Just burn Jussi’s NAA image to USB stick and that’s it.