Playback failed because $ couldn't connect to HQPlayer

Core Machine (Operating system/System info/Roon build number)

Intel Core i5 processor, SSD, Windows 10 (current), Roon 1.6 (Build 401) 64 bit.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Server machine connected through ethernet bridge to WiFi.

Connected via USB to Schiit DAC.

Description Of Issue

I can’t seem to get Roon to work with HQPlayer. HQPlayer is installed on the same machine as the Roon server. I have disabled all outputs in Roon except for HQPlayer, but when I try to play something, I get the message “Playback failed because $ couldn’t connect to HQPlayer.” Not sure what to do.

I’m sure you followed these instructions for setup but please check your settings again because other users reported that updating HQPlayer has reset the “Allow control from network” feature in HQPlayer.

I think I got it sorted out. I enabled “System Output” in the Audio section of the settings, and things seem to be working now. Thanks for the quick response.

Hello @Philip_Holt,

I would not suggest using the “System Output” to send the media to HQPlayer, you will be limited in sample rate if you use this method.

Can you please check the HQ Player Setup Instructions that Blackjack posted and give the “Allow control from Network” option a try?

You should then be able to select the zone from the Zone picker and have HQ Player working at the proper sample rates.



I followed the instructions, but how to configure Roon properly to communicate isn’t clear to me. I disabled system output. Here’s the configuration I currently have:

The settings interface for HQPlayer is detailed but relatively primitive, only allowing a choice between WASAPI and ASIO. They both seem to work, but I don’t know what difference the choices make. I’ve still got an evaluation version of HQPlayer. I don’t want to pay if I can’t get it to work right!

Hi @Philip_Holt,

If you scroll down to the “Networked” zones, does HQ Player show up there? Have you made sure to enable the Network Access in the HQ Player app and then have added it to Roon as per the instructions?

Step 1 : In order to connect to HQPlayer using any address other than localhost or , you must enable the “Allow control from network” feature in HQPlayer. This is the globe icon on the far right hand side of the HQPlayer toolbar:


Step 2 : In Roon, go to Settings/Setup/HQPlayer and click “Add HQPlayer”.

Step 3 : Enter the network address where HQPlayer is running :

  • If HQPlayer is running on the same computer as your Roon Core, leave the default localhost value, then press Add
  • If HQPlayer is running on your network but on a different computer , enter the local IP address of that computer, then press Add .


Roon and HQPlayer are both running on the same machine, which I have tried to set up as a headless server. I have Roon configured in the scheduler to start up automatically whether I’m logged in or not.

I got the HQPlayer to work once. Now I’m getting the same message again: “Playback failed because $ couldn’t connect to HQPlayer.” HQPlayer is currently the only output enabled on the Audio page of Roon settings. It seems that the network access button the HQPlayer toolbar doesn’t have any effect in this case because it’s running on the same machine as Roon.

When I connect via RDP to the server and login and run HQPlayer, things appear to wake up, but I can’t think of any normal operational situation where I’d leave a device on the network logged in.

I apologize if I’m not getting it!

I’m afraid I’m stumped. I uninstalled all the software and started from scratch. I installed Roon, and configured the computer to auto-login, etc. The computer is connected directly to a DAC via USB. Everything works fine if I play through the generic USB interface or the DAC driver for the USB.

I followed the knowledge base instructions for installing HQPlayer. I added it in Roon, then restarted the whole system to make sure everything was at its most initial state. Roon plays fine through the USB. If I choose HQPlayer, I still get the error message “Playback failed because $ couldn’t connect to HQPlayer.”

If the “Allow control from network” option is enabled or not, I get the same result. I cannot figure out what I’m doing wrong.

Suggestions welcome!!!

This message means that Roon is unable to communicate with HQPlayer.

How is HQPlayer configured in Roon (Settings|Setup|HQPlayer)?

As Roon communicates with HQPlayer over the network, even if both run on the same machine, have you allowed Roon, RAAT and HQPlayer in your firewall settings? If unsure, try disabling the firewall completely to test if communication works then.

Just to be clear,

In Roon, you have gone to Settings / Setup, scrolled down and clicked Add HQPlayer, then on the next screen put in localhost and then hit Add?



HQPlayer is setup over localhost. I’ve just gone in and made sure all the firewall settings are friendly. Will report back after the server wakes up again.

Yup to all.

I’m following all the instructions, and no joy. Always the same message.

I can then assume, that you, also, enabled HQPlayer in the audio tab, gave it a name and then have chosen it as your active endpoint.

In the settings/audio tab, is it showing localhost or giving you an IP? In my Pic, it is showing the IP address as Roon and HQPlayer not longer live on the same machine for me.


There was at least once I had to set HQPlayer up with my computer’s actual IP address instead of using “localhost”. You might give that a quick try.

In my configuration, HQPlayer shows up as localhost. I’ll try configuring it using the loopback address first, then the DHCP assigned one.

It couldn’t hurt to try. As I said, I had to use the actual IP for one setup I had. although that was awhile ago before the HQPlayer setup interface changed.

No joy. I turned off the firewall. I added HQPlayer as both and the local IP address. Nothing plays. Same error.

But HQPlayer is running? Have you tried to use HQPlayer standalone to play music and does it work?

I think I’ve solved the problem. I’m using the evaluation version of HQPlayer because I wanted to make sure the results would be worth the incremental cost. The evaluation version, however, starts with a dialog that must be acknowledged. Well Roon doesn’t know that, so the result is that all the software waits around until that dialog is cleared. I started up HQPlayer and left it running. After that, when I choose it in Roon, everything works as expected.

Since everything is running in a test bed, I’ll have to hook it up to my main system to A/B HQPlayer with the built-in Roon player, but at least I now know how to do that. After that test, I’ll decide whether coughing up the dough for HQPlayer is going to be worth it for me.

Opinions welcome. Thanks for the timely responses and suggestions. I was sure that the impediment would seem obvious once I discovered it!