Playing CD FLACs through a 5.1 home theater receiver

My home theater receiver (a Denon) has five “small” (i.e. non-full range) KEF speakers and a sub-woofer attached.

When I play FLAC files ripped from CDs, the receiver only plays through the “small” left and right speakers. This sounds very weak and tinny.

I’ve tried (and failed) to get the Denon to output to the sub-woofer, so I am wondering if there is a way with Roon that I can get it to take a stereo FLAC file and convert it to a 2.1. signal (i.e. including a sub-woofer component)? I would think this should sound much better.

What model is your Denon? On my Denon 3808, I just switch on the “7 channel stereo” option to use all the speakers…

What you need is a Meridian Processor and Trifield.
It amazes me that no other manufacturer licenses the technology but from a Stereo signal it creates a 5 Chanel mix that simply immerses you in a sound bubble.

You can’t shortcut the shortcut and I dont know what Roon can do.

That processing should be done in your Denon. Depending on the crossover value you have set (typically around 80Hz) or that the Denon uses all audio below that value should be sent to the Sub. The audio isn’t encoded as 2.1 it is just stereo.

1 Like

There should be a setting on your receiver (on my Pioneer, it’s just called “Stereo”) that performs the appropriate DSP to convert 2-channel to 2.1 (or 5.1 or 7.1, etc., if you choose one of the more fancy modes).

Most receivers also have a “Direct” (or “Pure Direct”, etc.) that simply passes the data straight through - which means the bass management (activation of the subwoofer) would be inactive and only the smaller speakers would work.

Make sure you’ve chosen the correct setting on your Denon.

Thanks everybody for the feedback. The message seems to be that my receiver (a Denon AVR-X2200W) should be able to do what I want. Specific responses below …

@Geoff. I could probably make this work if I dedicated the receiver to playing stereo, but it’s primary use is as a home theater as my main sound system is a KEF LS50 Wireless (amazing active speakers), driven by a Raspberry Pi / HiFi Berry Digi+ Pro in another room. I asked the question because I was trying to get good quality stereo sound easily through the receiver when I wanted to. Having to change the receiver settings (e.g. by turning off/on Audyssey MultiEQ-XT) each time I wanted to play stereo would be hard work.

@Chris. Although I am sure I could make it work with extra kit, as you suggest, I don’t really want to since it’s not my main sound system and I can’t justify the cost.

@Tony & @John. I did spend a couple of hours changing inputs/settings including trying: Optical S/PDIF, HDMI and Airplay (the first two connected directly to the Roon Core). It included playing around with various sub-woofer and “sound mode” settings, but I could not find a way that gave me half-decent sound.

… so I will keep on looking for a solution and, if find one, I will report back.

Thanks again.

PS. (Off Topic) Building a Roonbridge into the KEF LS50 Wireless would be amazing :slight_smile:

I’m not sure why you would want to turn off/on the Audyssey? I leave it on at all times. And the Denon should remember all the different settings set per input source. So for me, it’s a simple matter of switching between the input source used by my HTPC (for movie playback) and the input source used for the Roon endpoint (an RPi/HiFiBerry Digi+ using coax S/PDIF), where I have the 7CH Stereo setting in use.

On the rare occasions I want to have a 5.1 audio recording played back in 5.1, then I’ll use Roon running on the HTPC as a Control and Endpoint.

After receiving your email, I did some more digging around and found this in the manual for the receiver under “Stereo Sound Mode” (page 119) …

This mode plays 2-channel stereo audio with no additional surround sound processing.
- Sound is output from the front left and right speakers, and subwoofer if connected. (my emphasis)
- When multi-channel signals are inputted, they are mixed down to 2-channel audio and are played back with no additional surround sound processing.

… so I tried “stereo sound mode”, but it didn’t work. Listening to Dave Brubeck’s “Great Concerts” CD, the bass line is inaudible and no sound is coming from the sub-woofer. I also tried setting the Bass “Subwoofer Mode” setting to “LFE+Main” where the manual (page 194) says use … “‘LFE+Main’ if you want the bass signals to always be produced from the subwoofer”. Again no sound from the subwoofer. Using “multi-channel stereo” which you use in your system behaved in the same way - no subwoofer sound.

So it sounds to me like this behavior is a bug/feature of the receiver, or maybe it’s because I’ve connected the receiver directly to the PC running the Roon Core using an S/PDIF coax rather than using a separate end point.

I’m thinking that, at this point, I should give up since I really can’t seem to get this to work … unless you have any ideas.

Thanks again for your help.

Why don’t you try Multi Ch Stereo mode instead?

I did try Multi Ch Stereo mode. It plays sound through the surround speakers, but still nothing coming out of the subwoofer so its no better. Thanks for the suggestion.

I probably have one of the cheapest setup’s possible.

It’s a $500+ Samsung home theatre system.
I think it has a 8" subwoofer.

I don’t want to focus on musical taste:
The track:
Eminem -> The Eminem Show -> Business
Has quite a bit of music coming from the Sub even when the sound is transmitted from roon as 2.0.

I don’t think you can turn off the sub playback and the result will not be good.

Even with 5.1 the subwoofer channel is quite limited to extreme effects.
You’ll want to playback extra sound using the sub there as well.
Getting very heavy duty stereo speakers should solve the problem and should be able to work without a sub.

To me it sounds like something is broken and will need to be replaced. My guess is the receiver.

What crossover frequency is your sub set at, does your Music have any content below that frequency?

1 Like

If the subwoofer is in Auto mode instead of On, it needs a high volume of bass to wake up. Try setting a high crossover frequency and playing music that is known to have strong bass.

Alternatively, play a movie and skip to explosion scenes, and make sure that the subwoofer is working. Then stop the movie and switch to your music.

1 Like

I tested two channel SPDIF output to Denon AVR-3802 (ancient model). In all modes I tested - Stereo, Multi Ch Stereo, ProLogic II and even Direct, bass is routed to the subwoofer, using this album:

All is now fixed - although it took a while. The basic problem was that there was a bad connection to the sub-woofer, replacing the sub-woofer cable fixed the problem … so many apologies to everyone for the “wild goose chase” … :disappointed:

I also took the opportunity to use a miniDSP UMIK-1 microphone and REW to create a calibration file to load into the Roon DSP. It made a big difference to the sound quality. The approach I followed was:

  1. Turn off DSP for the Denon zone in Roon and adjust the sub-woofer level to get a decent basic stereo sound quality. This way, the DSP should have less to do. I was using Airplay from Roon to the Denon.
  2. Run Audyssey on the Denon to adjust the sound on the Denon for home theater use.
  3. Run REW on my laptop to create a calibration file - see “A guide how to do room correction and use it in Roon” by Magnus - thanks Magnus - your guide was really helpful.
  4. Fine tune (i.e. increase) the sub-wooofer level to get the sound I liked.

I am now very happy with the sound - particularly the clarity of the sound stage.