Plexamp: Volume Lower Than Roon and AirPlay Streams with RoPieeeXL 2023.11 (1176), Apple USB-C to 3.5 mm Headphone Jack Adapter, and Pi Zero 2 W

Greetings @spockfish and fellow RoPieee users!

I updated my Pi Zero 2 W to RoPieeeXL 2023.11 (1176) last night, and I noticed that the volume from Plexamp is much lower, roughly 50 percent, than the volume from Roon and AirPlay streams coming from the Pi Zero 2 W with the Apple USB-C to 3.5 mm Headphone Jack Adapter. I had this problem with a previous version of RoPieeeXL, but the problem was resolved with one of the previous RoPieeeXL updates. Sadly, the volume trouble in Plexamp returned after I updated to 2023.11 (1176).

I have made adjustments to the Plexamp playback settings (disabling loudness and limiting, and increasing/decreasing preamp gain) via the web GUI for Plexamp on the Pi Zero 2 W. These changes were made to the playback settings when the playback queue was empty, and they do not seem to make a difference. It seems as if the changes are not beings recognized by Plexamp on the Pi Zero 2 W in spite of the Plexamp web GUI recognizing and retaining my changes. Restarting the Pi Zero 2 W does not correct the problem.

Does anyone have a solution for this problem?

Best regards,

RU

if you look at the Plexamp browser interface during playback, is the volume slider set to the max level?

Yes, with the volume slider set to the maximum level in the Plexamp web GUI on the Pi Zero 2 W, the volume from Plexamp is approximately 50% lower than AirPlay and Roon audio streams.

is loudness analysis enabled in your Plex server settings?
(plex.tv > server / settings > library … analyze audio tracks for loudness)

loudness analysis + max volume slider + playback settings (disable loudness leveling, preamp, EQ) … i think that’s all?

I tried disabling all of those settings earlier (with nothing in the play queue and even restarting the Pi Zero 2 W), and there was no audible change in behavior, sadly.

The only setting change that is audible is adjusting the volume slider. As I mentioned earlier, the the maximum level produces roughly 50% of the volume of AirPlay and Roon audio streams from this Pi Zero 2 W with the Apple DAC.

Adjusting preamp in Plex doesn’t affect regular volume it’s only for replay gain so if you have that off it’s doing nothing at all. It’s just the loudness target above or below -18bfs which is the default.

with most modern music there should be an audible difference with vs without loudness leveling (and note that Plexamp will make loud material quieter, but it won’t make quiet material louder)

feedback/logs to @spockfish might help at this point … it sounds like you’re checking/changing the right Plexamp settings

Dear @tgp-2 and @Simon_Arnold3:

Thank you for all of your suggestions. It seems as though the playback settings are “fixed” in spite of what I enable or disable via the Plexamp web GUI on the Pi Zero 2 W. I had this problem with a previous version of RoPieeeXL, but the problem was resolved with one of the recent updates. AirPlay and Roon streams to the Pi Zero 2 W are fine.

Best regards,

RU

@RoonUser657932327 i now have a pi zero 2w … so far, i haven’t been able to reproduce what you’re describing … Plexamp volume level matches that of Roon and Airplay

one idea since it seems like changes made in the Plexamp browser interface aren’t getting through to the device … go to the Plexamp browser interface (ropieee-hostname:32500) and use the browser to delete all cookies and site data for this Plexamp browser page … then reload the page and you’ll do Plex sign-in again … and then try changing playback or other Plexamp settings … with any luck, your changes will take effect this time

Dear @tgp-2:

I appreciate your getting back to me and offering some suggestions. I tried instigating Plexamp audio playback through the Pi Zero 2 W’s Plexamp browser interface with the most recent stable release without success. I tried again in the beta release of RoPieeeXL using a “clean” browser, and I am still experiencing reduced playback volume from Plexamp through the Pi Zero 2 W with the Apple USB-C to 3.5 mm Headphone Jack Adapter.

Plexamp and Roon are at roughly the same volume when streaming from other systems to the Pi Zero 2 W via AirPlay. When I stream or initiate audio playback through the Plexamp service on the Pi Zero 2 W, the volume is about 50% lower than the volume of audio playback through the Roon and AirPlay services on the Pi Zero 2 W.

I appear to be the only person with this problem, so I am planning to erase RoPieeeXL on my Pi Zero 2 W and start over. It may be a few days before I can re-flash and reconfigure the Pi Zero 2 W, but I will post my results here. I will try the most current stable build of RoPieeeXL first. If I encounter the same problem with the reduced volume in Plexamp on the Pi Zero 2 W, I will re-flash and reconfigure using build 2023.9.0, which I believe is the build where I did not experience this problem.

Thank you again for your help.

Best regards,

RU

P.S. Are you managing the Plexamp service in RoPieeeXL?

not managing, but i’m familiar with how Plexamp service works so trying to help :slightly_smiling_face:

before you resort to reflashing, recommend using RoPieee advanced tab to Send Feedback for spockfish to review

Dear @tgp-2:

I did not submit feedback since I was unsure if it was appropriate to send unsolicited feedback to Spockfish. I had a bit of time last night for testing and troubleshooting, so I reinstalled RoPieeeXL 2024.01.1 on my Pi Zero 2 W with the Apple USB-C to 3.5mm Headphone Jack Adapter. I encountered the problem with reduced playback volume initially; however, the problem disappeared without explanation. Thinking that I had made a mistake while configuring the RoPieee services, I re-flashed the Pi Zero 2 W drive and configured the RoPieee services a second time with similar results.

The Plexamp service on the first and second installations and the AirPlay 1 service on the second installation played with approximately 50% reduced volume initially. Full-volume playback returned to these services after playing an audio stream from Roon to the Roon service within RoPieee. I made no changes to the volume level in Plexamp, both on the RoPieee and Plexamp applications streaming to the RoPieee, and the AirPlay 1 service was configured with volume control disabled. I did not test the volume of the AirPlay 1 service during the first installation since I was preoccupied with testing Plexamp, but I did test the Airplay 1 service during the second installation and experienced roughly the same level of reduced volume that I experienced with the Plexamp service within RoPieee.

Rebooting the Pi Zero 2 W does not cause the volume to be reduced in the Plexamp and AirPlay 1 services within RoPieee, thankfully. I cannot say if playing an audio stream from Roon to the Roon service on the RoPieee was responsible for correcting this problem, but full-volume playback returned to these service after streaming audio from Roon to the Roon service on the RoPieee during both installations.

I believe some Linux distributions misidentify and misconfigure the Apple USB-C to 3.5mm Headphone Jack Adapter. Could some of the services within RoPieee be misidentifying and misconfiguring this device, too?

Since my current installation is working, I am going to pause my troubleshooting. If the trouble returns and this thread is still open, I will post here.

Best regards,

RU

Greetings @spockfish and @tgp-2!

I had no trouble with reduced playback volume after upgrading from version 2024.01.1 to version 2024.02 today. If I re-encounter this problem and this thread is open, I will post here.

Best regards,

RU

Greetings @spockfish and @tgp-2,

It appears that RoPieee’s Roon service is setting the maximum playback volume for RoPieee’s Plexamp service on my Pi Zero 2 W. I have tested this process several times, and it is repeatable consistently with my RoPieeeXL 2024.02.1 configuration. Do you mind following these steps to see if the problem is repeatable with your configurations?

  1. Reduce the playback volume for RoPieee’s Roon service to “25.” (I used the latest stable macOS and iOS releases of Roon.)
  2. Stream a music file from Roon to RoPieee’s Roon service.
  3. Stop playback to RoPieee’s Roon service.
  4. Wait a few seconds for Roon to release the RoPieee.
  5. Open Plexamp and play the same music file that was played in Roon to RoPieee’s Plexamp service. (I used the latest stable macOS and iOS releases of Plexamp.)

For me, RoPieee’s Plexamp service plays the file back at reduced volume, which appears to match the “25” volume level that has been set in RoPieee’s Roon service. I cannot increase the volume in Plexamp; it is set to the highest level. The only way I can restore full volume to RoPieee’s Plexamp service is to switch back to Roon and increase the volume to the maximum level in RoPieee’s Roon service.

Another oddity I discovered is that I can adjust RoPieee’s Plexamp service volume with Roon while audio is streaming to the RoPieee’s Plexamp service. Roon’s playback destination must be set to RoPieee’s Roon service for this behavior to occur. I do not understand how RoPieee’s Roon service volume control can adjust the volume in RoPieee’s Plexamp service. I assumed the services were completely separate on RoPieee, and I cannot adjust RoPieee’s Roon service volume with RoPieee’s Plexamp volume service.

I do not mean to waste your time with my posts regarding these volume issues; however, I am concerned about equipment damage when one switches between RoPieee’s services that may have extreme differences in volume between them. I hope this anomaly is unique to my configuration.

Best regards,

RU

sounds to me like volume control in Roon is set to “Device volume” … change this to “DSP volume” if you want Plexamp and Roon app volume levels to be unrelated

volume level is a combination of underlying (OS/Linux) device mixer/gain setting AND the app’s software/DSP volume setting … Plexamp only uses software volume control, Roon has the option of either device or DSP … changing device volume in one app will affect overall volume level in other apps

3 Likes

Dear @tgp-2:

Changing Roon’s volume control to “DSP volume” resolved the problem. Many thanks for the instruction! I did a bit of experimenting with playback to RoPieee’s AirPlay service, and I discovered that Roon, macOS, and iOS seem to use “device volume” to take control of the volume level when streaming to Ropiee’s AirPlay service, too. I do not see the option use “DSP volume” in Roon with AirPlay streaming to the AirPlay service on RoPieee, but that is not a major concern since I wouldn’t use the RoPieee’s AirPlay service for Roon playback. However, I do send AirPlay audio streams from macOS and iOS to the AirPlay service on RoPieee. I do not see a way to use DSP volume when streaming AirPlay audio content on macOS and iOS to RoPieee, so I am assuming that I will need to remember to be sure the volume is set to maximum after I end every AirPlay session to Ropieee, correct?

Thank you for taking your time to explain these settings to me.

Best regards,

RU