Port forwarding fails on a new AT&T Internet Air for Business 5G Gateway

Roon Server Machine

Intel NUC i7 8GB
Ubuntu 22.04 LTS
Roon Server

Networking Gear & Setup Details

  1. Who is your internet service provider?
    AT&T Business

  2. Please list the make and model of your modem and router?
    AT&T Internet Air for Business 5G Gateway
    Model: NCM1120D2-D323
    On this model it appears that “Bridge Mode” is not an option:

  3. Do you have any additional network hardware, like additional routers or managed switches?
    No additional routers or switches

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Mojo Audio Mystique DAC connected via USB to the Intel NUC

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Originally, Roon ARC was working great with an older hardwired router. But AT&T wanted to almost double my monthly fee to keep it. So they “upgraded” me to a wireless router.

On this new router I have the Roon Server setup with the same static IP of

I have port forwarding manually setup:

The basic setup of my network is the new modem and three machines hardwired into the ethernet ports: My workstation, the Ubuntu Roon Server & another Ubuntu storage server:

The Roon settings appear to match the router settings:

The modem’s instruction manual has a section on Port Forwarding and the administration web page has preset defaults for common protocols and popular games so there’s an optimistic assumption on my part that Roon ARC could be configured to work as well with this new hardware.

But I keep getting error messages similar to this:
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:404,“error”:“<?xml version=\"1.0\" encoding=\"iso-8859-1\"?>\n\n<html xmlns="http://www.w3.org/1999/xhtml\” xml:lang="en" lang="en">\n \n 404 Not Found\n \n \n

404 Not Found

\n \n\n"},
“external_ip”: {“actual_external_ip”:“null”,“actual_external_ipv6”:“2600:aaa:bbb:nnn:ddd:ddd:ddd:eee”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

I have disabled both the IPv4 & IPv6 Firewalls. I have tried moving the server into the DMZ. I have tried enabling UPnP. I have toggled UPnP. I have rebooted the Roon server. I have rebooted the router. I have connected a laptop to the old router to compare the old setup with the new setup but I can’t spot any difference. After I switched routers, ARC ran for a few songs before failing but I wondered if that might have just been some buffered music from the old setup. If so then the new setup never worked.

So basically my optimism is fading as I’m beginning to run out of ideas. Hopefully I just overlooked a nuance but I can’t seem to see it if I did. Anyone else have any suggestions?

Wireless 5g service is most likely CGNAT and your older hardwired was not. If the new service doesn’t support ipv6 you most likely won’t get it to work.


Hi @Darryl_Caillouet,

If you’ve thoroughly tested your own network for a second NAT layer and haven’t found one, then the blockage will be upstream of your account. Carrier-grade NAT or other implementation that blocks ARC’s connection to RoonServer is unfortunately quite common with business-tier accounts.

A quick solution would be to install a proxy-mesh VPN with robust NAT traversal on both your RoonServer and ARC machine, and connect using the resulting virtual subnet.