Port Forwarding on AT&T with Luxul router

Roon Core Machine

Windows 10 PC, Intel Core i5 4460, 8GB RAM

Hi there. Casual Roon user, but I like the interface a lot and am excited to use ARC out of the house.

I used the guide to setup my router (Luxul Epic 3, also known as XWR-3150). It does have UPNP (and NAT-PNP) which I turned on, but it didn’t work.

I tried port forwarding. I changed the default port number, matched in from the Roon to the router, and still got the 504 timeout error.

To check the port I opened a telnet window, and was able to check the port which opened successfully (Windows Features>enable telnet>open a cmd prompt>telnet 192.168.1.xxx 5xxxx)

So I believe the port is in fact open both on the LAN and WAN side.

Not sure where this is failing, but if someone could shed some light that would be helpful. I did see the previous message about restarting the AT$T gateway, but I already previously had it configured for passthrough, I did reboot my Luxul router, but that didn’t change anything.

Any suggestions are appreciated.
Thank you,

Networking Gear & Setup Details

  1. Who is your internet service provider? AT&T

  2. Please list the make and model of your modem and router? Luxul XWR-3150

  3. Do you have any additional network hardware, like additional routers or managed switches? AMS-2600 switch

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? No

Connected Audio Devices

Not sure what devices you mean. I do have Sonos in the system and use it via WiFi

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“76.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hi @Russ_Keck1,

Welcome to the Roon cummunity.

Could you please post a screenshot of the Roon Arc tab in the Roon app? You can find it in the Roon App under Settings → Roon Arc.
Also please post a screenshot of your port forwarding rule. Be sure your public ip address isn’t shown.

Kind regards,


I fixed it. Turns out that the issue was that I changed my router and my AT&T Gateway was not properly configured to the MAC address of the new one, so was not properly acting as a passthrough bridge. So the port forwarding wasn’t working properly.

Reconfigured the passthrough settings, and now the Luxul port forward rule is working as it should.

Thanks for the quick reply!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.