Port Forwarding settings for IliadBox

ok, so…
I did set Port Forwarding on my router (TP-Link Deco X90) as in https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Overview

my ISP’s modem/router is an IliadBox and it does DMZ to my router’s IP (to avoid double NAT)

but ARC doesn’t work so… I tried setting a port forwarding on my ISP’s router but… it doesn’t let me save the rule

what am I doing wrong here?


Hi Paolo,

Could you please explain what your network setup is. As far as i understand by now, IPS modem/router and a TP-Link Deco X90).

  1. What is connected on which modem/router
  2. What is the error message in the Roon app when testing ARC?

I’m no expert on this topic, but as mentioned in the post by Roon (see below) setting a modem/router in DMZ is not way to go.

Kind regards,


Paolo, it looks like there is an error in the start port. Check if it’s all numbers, and that there’s no space after the 55000 by accident.

yup: definitely looks the issue is there

I typed “55000” in the “start port” and the other two (“final port” and “destination port”) where auto-filled so… looks I have to type a different number somewhere but… where? and… which number? :sob:

DMZ is set on my ISP’s modem/router only to avoid double NAT
no DMZ on my router

Roon gives you in the settings under Roon Arc the correct port number:

Check what number it gives you. Maybe 55000 is already used by something else. In my case It gave me 55002. (You can use any number between 10000 and 65000 as long as it is not used by other stuff)

1 Like

Try to avoid using DMZ for security reasons. Your computer is exposed too much.
Read my solution here: SOLVED: Do I really need a static IP to make Roon Arc work? - Support / Port Forwarding Help - Roon Labs Community
Try it out, it might help…

as I wrote… DMZ is only set on my ISP’s modem/router (to avoid double NAT)
my own router, which follows in the chain and is the one and only “thing” connected to my ISP’s one, does all the firewalling :wink:

1 Like

Well, maybe I didn’t express myself well enough, hehe.
What I meant was, just try not to use it. In my case, DMS is also set up on my ISP modem or better said: the DMS address exists. But I’m not using it in my second modem. I think it’s kinda normal that your ISP provides an address for DMZ. It then only depends on what you do with it…

thank you so much @JST1963 :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face:

problem was… my ISP’s modem/router only allows port forwarding with 16xxx as max port # :no_mouth:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.