Port Forwarding: Solutions for Verizon FIOS Modem/Router?

Thanks for sharing this information! Has anybody out there been able to get Verizon FIOS to do either of these options?

Hi @RoSko,

I apologize that we missed your post in another thread; I understand you’ve been without port forwarding for some time now. I’ve split your post into a dedicated topic thread since the team can respond most efficiently when threads are per-issue.

Do you have a second router in your setup? What’s the make/model of the second router in your setup?

Verizon hasn’t implemented carrier-grade NAT across all of their tiers and accounts as far as we’ve been able to tell on this forum; there are a number of users who have successfully configured a FIOS gateway with a second, third-party router, even in a mesh setup.

Generally, this requires setting both a TCP and UPD manual port forwarding rule in the Verizon router web administration page, and then setting similar rules in any second router to point to the same destination, your Core (or enabling UPnP). The Fios rules should resemble these below, and are usually accessible in the web admin under Advanced → Security → Port Forwarding, or something similar:

To reiterate, create two rules: one for the TCP protocol, and one for the UDP protocol, both with the same Core static IP address and listening port.

To confirm your Core’s static IP and listening port, go to Roon → Settings → ARC, and they’ll be listed.

Once you’ve set these rules in the Fios router, set the same rules in your second router, if you have one.

Note: disable UPnP on the Verizon router once you’ve set these rules.

We’ll be watching for your response.

I have a Verizon FIOS Router and a Google Nest. I created the port forwarding rules for both, using the port number on the listening port in RoonARC. I also have a Verizon Fios Extender. Does the Extender also have to have port forwarding as well? (I did not do this yet.)

Here is what I forwarded on the FIOS

Also, how do I set up a static IP for my Roon Core?

Thanks!

Any advice based on the error codes I am getting? Thank you!

Did you turn off UPnP on the router as suggested? If not, try that and then reboot everything.

Yes, and this is the error I get:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“108.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Any other ideas? Thanks!

And, you have manually set your Port Forwarding as well as shown in the above information?

Yes, I set up the port forwarding in my Verizon FIOS Router as shown in post #4 above. I also set up the same port forwarding on my Google Nest. No luck. Any idea what the error message in post #6 is telling us? Thanks!

The error you get now tells us two things:

  1. UPnP isn’t enabled (we know this, you turned it off)
  2. Port forwarding isn’t working yet.

Please describe the entirety of your network gear. From your last post you have both a Nest network and the Fios router? What else is there? What’s cabled into what?

Hi @RoSko,

I wanted to follow up here, as it’s been a few days. Were you able to resolve the port forwarding timeout by enabling UPnP or creating a manual port forwarding rule?

We’re here to support, so you have a chance to try Roon outside the home with ARC.

Thanks, Connor. None of the suggestions worked and I gave up on being able to solve the problem. Instead, since I don’t have Verizon FIOS for TV, I didn’t need the FIOS router and I hired someone to route the ethernet cable from the outside directly to my Google Nest. So, don’t have a double NAT anymore because I only have one router now.

But I have a new problem. My iPhone 11 Max always says “poor connection” no matter how many bars I have. So I still can’t use Arc. Other phones have no problem. Any advice on how to correct?

Thanks!

I was able to fix the “poor connection” problem by uninstalling and reinstalling the Roon ARC app.

1 Like