Port Forwarding Support for AT&T BGW210

I’m having a similar issue with AT&T and Eero, was this ever solved?

I followed the instructions for the AT&T Modem here: Arc port-forwarding solution: ATT BGW320 and Asus AX-88U

Here are the settings I have on the modem:

On passthrough if I choose from list, the dropdown gives me a secondary Eero in the garage, so I pasted the Mac address of the NUC running the Core.

Roon on the desktop machine shows zero diagnostic data and refresh produces noting - though it is connected to the Core - and playing music on this machine.

Roon ARC on iP{hone is connected - In local only mode - and works on my LAN.

Any help would be most appreciated!!


@Graham_Bird, I moved your post and created a new thread so as not to confuse issues with the OP’s previous support request.

I’m not sure you need IP Passthrough active on the AT&T gateway. You need the following setup verified for port forwarding in a two-router setup such as yours:

  1. On the AT&T gateway, create a port forwarding rule pointing to the IP address of the eero router using the port number for Roon ARC shown under you Roon Settings → Roon ARC tab.

  2. Then create a port forwarding rule on the eero pointing to the IP addresss of your Roon Core MBPro laptop, again using the same port number for Roon ARC as shown in Roon.

While there is no ARC error message showing on your Mac, can you see if your iPhone has one and if so can you post it here?

My situation is more complicated.

We did an online chat with ATT and got the router set to open a port at 55000. I got no error message on the Core (My MacBook Pro) It was set to go, and then I got a message over Roon ARC that said “Poor Connection. Try Again.” I had no idea how to fix that.

Trouble shooting that issue, we set Eero on bridge mode to eliminate the NAT. Eliminating that issue with bridge mode caused my TV’s and Naim Streamer to get kicked off the network for a couple of hours. We took a step back to reboot the Xfinity wireless boxes to get TV going again and have some tunes from the Naim rig. I expect the issue is the Xfinity wireless “cable” boxes but that is a deep rabbit hole.

So not on Arc yet. But will try again after a break. Everything else is working, thank goodness. Mom needs her CSI and NCIS!

I do love the Arc idea and have both the hard drive and the data plan to enjoy it. Just ran out of time on the holiday weekend.

@Skip_Clemmons, can you please explain more about your home network? Is AT&T or Comcast your broadband provider, or do you use both providers? Reading about Xifinity’s wireless cable units implies that you must have Xfinity cable service for these to work.

How is your home network configured, as in what is connected to what, what network devices do you have, what are your connected endpoints, etc.? This would help with diagnosing what you are experiencing.

Try setting the playback quality in arc from auto to original.

1 Like

Adding to @Rugby’s suggestion, you also could perform a reset from within the ARC application which may repair some of the network connection issues.


It is crazy I know.

We have been on ATT forever for broadband, now fiber, in our neighborhood. We went Comcast for cable for years and have been happy with their service. We started having problems with the image freezing on Comcast. I took a cable box into Comcast to get it fixed. They swapped it out for a small wireless Comcast receiver. It worked so well vs. the wired box, that I took the second Comcast box in and it worked, too. My two TV’s are now wireless on Comcast Xi5-P wireless boxes. I no longer have Xfinity cable per se. All my Xfinity is wireless. Everything else is on ATT. I have no idea how it works or what is connected to what. It is so hard to talk to anybody at any of these companies!



Just got it working with the reset working above. Tomorrow on the road will tell the tale. Fingers crossed. Thanks for the help.

Not working this morning. Arc says “Make sure your Roon Core is turned on and configured for remote access.” What is the key to remote access if the port is forwarded as discussed?

I would reboot the Core and see if that helps.

@Robert_F Thanks for the move.

I went to the machine to start to tackle your suggestions - having touched absolutely nothing since the setup described yesterday.

Lo and behold, ARC Settings now shows that everything is working:

So, I shall test it in the car today in prep for an overseas trip. May as well give it the ultimate try!

Thanks for suggestions and help. I may return!!


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.