Port forwarding with Ubiquiti EdgeRouter

Roon Core Machine

MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
2.3 GHz Dual-Core Intel Core i5
8 GB 2133 MHz LPDDR3

Networking Gear & Setup Details

Ubiquiti EdgeRouter 5 PoE
Netgear Orbi RBR20
Netgear Orbi RBS20

Connected Audio Devices

AirPlay 2 and Chromecast

Number of Tracks in Library

31,690 tracks

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“71.114.74.84”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.

Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridgemode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service providerand what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thanks!

Just to be clear, you’ll have your ISP modem/router => EdgeRouter => Orbi RBS20

This is likely to give you an issue

Yes, is your ISP modem/router in modem mode only?
EdgeRouter - I’ll send a link later to help
Orbi RBS20 - not familiar with these, are you using them as an access point and router turned off?

@Omar_Chaudhry

Link to help you with the EdgeRouter.

Thanks, Gentlemen. Both of you got me thinking about this more in the right way. I’ve got ARC working now. :slight_smile:

@Geal_us_Dearg_a_suas - You’re understanding of my setup is close. I run a Verizon FiOS ONT directly to my EdgeRouter and then use the Orbi RBR20 as a secondary router with two RBS20 devices as WAPs.

In other words, INTERNET => EdgeRouter => Orbi RBR20 => Roon Core, where

  • EdgeRouter eth0 is the WAN port
  • EdgeRouter eth1 is the LAN port with IP 192.168.w.1
  • Orbi RBR20 eth0 is the WAN port with IP 192.168.w.x
  • Orbi RBR20 eth1 is the LAN port with IP 192.168.y.1
  • Roon Core is on the LAN port with IP 192.168.y.z

Which means I needed TWO port forwarding rules:

  1. EdgeRouter: WAN = eth0, LAN = eth1, enable hairpin NAT, forward to 192.168.w.x
  2. Orbi RBR20: forward to 192.168.y.z

All port forwarding rules use the same port specified in the Roon ARC settings.

So once I modified the IP in Rule #1 and created Rule #2, voila!

Again, thanks, guys!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.