Port Forwardning UDM PRO

Roon Core Machine

Roon Optimezed Core Kit 2.0

Networking Gear & Setup Details

  1. Who is your internet service provider?
    Servanet and Bredbandsbolaget

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?
    only switches

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“178.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Dont want to use UPnP due to security aspect. Have created port forwardning rule on 55000

Hi @LarsB - I had the same concern as you with enabling UPnP on my UDMP just to support ARC.

You only need to enable UPnP briefly to allow ARC to connect itself to your Core. Once it’s connected, you can disable UPnP on the UDMP and then just set up a standard port redirect in the firewall settings.

@Steven_Wilkes Thanks for input to temporary allow UPnP - got a little bit further but I guess I run into the Multiple NAT problem.
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“178.aaa.bbb.ccc”,“router_external_ip”:“100.ddd.aaa.eee”},
“status”: “status”: MultipleNatFound,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I update with my findings, internet service provider has changed to 100.x and not public IPs. Need to contact customer service to have it changed. Hope this will solve problem when it’s done.

1 Like


I think you are right. I think your ISP is using CG-NAT.

I hope they provide you with a public ip.

Kind regards,


1 Like

Hi @LarsB,

I’m sorry to hear that you’ve encountered an issue with carrier-grade NAT. Out of curiosity and for the benefit of other users on the forum, are you able to confirm your internet service provider?

It might be helpful to know the particulars of their implementation, and whether they have a dual-stack IPv6 infrastructure in place.

Roon is working on additional solutions to integrate ARC more smoothly with ISPs that have carrier-grade NAT, but these tickets are still in progress and won’t necessarily accommodate every situation. We should have more information in the coming weeks.

In the meantime, I recommend glancing at some of the #tinkering threads involving TailScale or even basic consumer VPNs. Here’s an example. Is there a way to get ARC working over VPN?


@connor is correct. I’m a UniFi user and I believe you’ll have the access to a VPN using the Wifiman app. You need to enable the Teleport function in settings.

Select Teleport and then…….

Once enabled you’ll need to generate the link and click on it to open it in Wifiman. It also shows an App Store link for Wifiman.

Get back to me if you need further help. There are other VPNs (free) that work. Tailscale wasn’t as good for me.

First of all thank’s for all great input! @AMT I have now setup Wifiman and teleport with your instructions, and it works flawless for me! No need for portforward or UPnP. This solves the problem and with higher security. @connor The provider is called Banhof (bahnhof.se) and is one of Swedens bigest providers. Can’t tell anything about how they implemented NAT, only information that I found is how to order for a public IP. Google translate from swedish: Beställ Publik IP - Bahnhof I plan to order this for implemenation next week since I don’t like the possible NAT preformance/response time overhead. Let me know if you need anything/logs etc. I could post support case to provider if you tell me what to ask in it? Once more thanks for all help :grinning: :tada:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.