Problem Installing Roon on Ubuntu - Help Wanted

I installed Ubuntu 22.04 LTS. Installed wine-7.8 according to this instruction:

Launched the script

Changed the path to the correct in

nv WINEPREFIX=$PREFIX wine $PREFIX/drive_c/users/$USER/Local Settings/AppData/Local/Roon/Application/Roon.exe -scalefactor=2


env WINEPREFIX=$PREFIX wine $PREFIX/drive_c/users/$USER/AppData/Local/Roon/Application/Roon.exe -scalefactor=2

However, after starting, nothing happens. See screenshot:

What could be the problem?

Hello @Dmitry_Bukhtyak - welcome to the forum. I’ve moved your post from the thread where you put it, because you are more likely to get help with the question being asked when it is posted as a new topic.

These steps work for Ubuntu 22.04. IIRC the path has changed in the startup script. However, I’m away, so can’t confirm. Incidentally, you don’t need wine32.

Download the archive from extract. Then run the the following commands.

$ sudo apt update && sudo apt install wine winetricks wget
$ cd ~/Downloads
$ ./

Let the script run, and when the installer finishes, exit without running Roon

Edit the shortcut, depending on your display.

~/ for 1920x1080p screen.

   env WINEPREFIX=/home/martin/my_roon_instance wine /home/martin/my_roon_instance/'drive_c/users/martin/Local Settings/Application Data/Roon/Application/Roon.exe' -scalefactor=1

Edit the shortcut in ~/.local/share/applications/roon-on-wine-desktop:

[Desktop Entry]

To have audio working, Roon Bridge needs installing, i.e., to play through a DAC. Download the easy installer from

cd ~/Downloads
chmod +x
sudo ./

I noticed that the roon application was installed even without a script ( Wine-7.8 and the latest roon64 app installer automatically installed the required dependency.

I ran the install like this:

wine RoonInstaller64.exe

The roon application starts normally!

There is only one problem. If the application is closed, then the process remains hanging. This process must be killed manually, otherwise the application will not be relaunched by clicking on its shortcut.

The hanging application is not happening to me on Ubuntu 22.04 (or before) but I am using wine-stable.

(The only issue I have is the high CPU load as described in the other thread where you had posted at first, but you don’t seem to be experiencing this?)

The wine-7.8 version does not have a stable release at the moment. So I installed devel.

How are you running the stable release on 22.04?

I simply installed wine from the default Ubuntu repositories. Never had any problem with this for Roon.

(After the annoying high CPU usage started, I tried wine-devel from Wine HQ as well, but it did not improve anything, so I switched back to the default one)

.NET 4.0 is not enough to run Roon. Are you sure you used the current installer script and not something older? Current one contains:

wget '' -O ./NDP472-KB4054530-x86-x64-AllOS-ENU.exe

_wine "Installing .NET..." ./NDP472-KB4054530-x86-x64-AllOS-ENU.exe /q

Is there the file NDP472-KB4054530-x86-x64-AllOS-ENU.exe in the same directory as the install script?

Unlikely. If this was a new Wine bottle, then you miss .NET and use Mono instead.

Probably (IIRC) an issue with Mono.

I ended up using a bottles app:

Installed the 32 bit version of bottles package. And 32 bit RoonInstaller.exe

Roon run inside bottle app. I also close it from there.

Everything works well!

1 Like