Problem moving my collection to a new NAS

I needed to expand the storage capacity of my NAS and discovered that I was unable to do so with the existing device. As a result, I bought a new NAS (to simplify things, both the new and old devices were made by QNAP) and copied all of my music files to the new NAS.

I followed the instructions on the KB article and backed up the Roon database, disabled the old storage location, stopped the Roon server on my NUC and quit Roon, the restarted the server and Roon.

I then tried to edit the storage location to point to the new NAS. I was assuming that it would find the new device and everything would work immediately. However, it has been more than 24 hours and Roon has not completed adding the network share (nor has it generated an error message).

Is it possible that this is normal? I have a large collection of music, but the new location is an exact copy of the old one and the Roon database is completely up to date.

If this behavior is not normal, I have one thought that might explain the problem. In order to make sure everything works flawlessly, I have assigned static IP addresses to my NUC, the NAS and my DAC. After disconnecting the old NAS I assigned the old address to the new NAS, thinking this might make it easier for Roon to find the new NAS. Is it possible that this was a mistake and Roon would prefer to find the new NAS at a different IP address?

Thanks in advance.

Have you tried to replace in Roon the name of uour NAS ‘Music-Server’ by its IP-adress:
so something like \\home\music

And another question. Are you sure about your directory structure on your NAS? I am not familiar with QNAP, but I have never encountered a ‘home’ directory on a NAS


Thanks for the advice. Before letting Roon run for the past day, I also tried cancelling adding the share and using the IP address, but got the same result.

I am fairly confident about the directory structure. The old QNAP NAS did not have a home directory, but the new NAS automatically set up a series of folders, with home being the primary one. The address I am using for Roon is identical to how I mapped the drive in Windows.

Can you map to the new nas from a pc without issue ?

Do that so you know exactly how the directory looks.

Does your new nas have a new IP address or does it assume the old nas address ?

Yes, I can map the directory in Windows with no problem.

After removing the old NAS, I changed the IP address of the new NAS to be that used previously for the old NAS. Could that be the problem? I can assign a different IP address to the new NAS.

Also, based on the responses, would I be correct in assuming that there is no reason this should be taking so long.

If so, I will assign a new IP address and see if this resolves the problem.

I should not take that long, in fact, it should find it almost immediately

Thanks - I’ll close Roon and try another IP address

1 Like

Thanks for all of the help. Assigning a new IP address did the trick. Once I pointed Roon to the new location, the following screen made it clear that it Roon was still trying to maintain the link to the address for the old NAS. I deleted that and everything is back up and running

1 Like