Problems connecting with RoonCore on Innuos ZEN MkIII using Qobuz

Core Machine (Operating system/System info/Roon build number)

Innuos ZEN Mk. III (Powered by innuOS version 1.4.3) connected via LAN cable to network switch
Apple iPad Air (iOS 13.4) as remote control for the ZEN and Trinnov Amethyst

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  • Unmanaged network switch: Zyxel 5 Ports Gigabit Switch GS-105B V2 (I also tested another D-link 5 port switch with the same behavior)
  • Router: AVM Fritzbox 6490 Cable (Firmware Version 7.10.)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Trinnos Amethyst (Version 4.2.5.1+ RAAT SDK Version 1.1.21) connected via LAN cable to network switch
Qobuz high res account (currently a test account)

Problems:

1st problem:
The Innuos ZEN Mk. III is connected to an unmanaged simple network switch (see above). Also my Trinnov Amethyst is connected to this switch. The network switch is connected via LAN cable to my AVM Fritzbox 6490 Cable router.
Here was the first problem that I was not able to find the Innuos ZEN during the first time setup although it was displayed correctly in the network devices page in my Fritzbox 6490 router. (A connection to the ZEN server using the IP address was not possible)
The DHCP IP address was set up correct (same network area 192.168.178.XX no different subnet mask). But I was not able to call up the first setup page via “my . innuos . com”. Here it seems that my Fritzbox router blocks the connection to this page (DNS-Rebind problem? No correct port forwarding configured?)
After having configured port forwarding (UDP 4003 and TSP 4100-4200) and also added the website “my.innuos.com” and also “zen.fritz.box” to the DNS-Rebind exception page in my Fritzbox, I was able to connect via the iPad to configure the whole system.
But when I turned off the Innuos ZEN the first time (using the power button at the front of the device) and tried to turn it on again, I was not able to connect to the Innuos via my iPad again. (This problem happens each day when I want to power on the Innuos again).
The only workaround I found was to reboot my Fritzbox router every time. Then I am able to connect to the Innuos again. (Here I am not sure if the port forwarding and the DNS-rebinding exception configured in my Fritzbox router are really solving the problem or if the reboot of the Fritzbox established the connection.)
For me it seems that perhaps the Fritzbox 6490 cable router caches some important information which prevents a reconnection to the Innuos when I turned it off and on and try to connect again using my iPAD.

Second problem:
When I connect to the Innous ZEN Mk.III (configured a Roon core server) using my workaround (see above) the connection to my Qobuz account calls up an error: “error loading page”.
As a result only the albums from Qobuz which I added to my Roon library are displayed and can be played. But the search function to the Qobuz database (in the internet) is not working any more.
E.g. When I try to search for an artist in only the artists from my local stored database (stored in the Innuos ZEN / Roon database) are displayed. No results from Qobuz are returned. (Also no Qobuz playlist is working any more).
Here I tried to disconnect my Qobuz account (using “settings” > “services”) from Roon and to reconnect it. But this also does not solve the problem.
The only workaround which I found after a long search was to delete the Roon database on my Innuos ZEN server (via the configuration page of the Innuos) and then to connect to the Innuos ZEN as “new Roon core server”.
As a result my complete library has to be scanned and rebuilt each time from Roon. But after that time consuming and annoying procedure my search functionality using Qobuz (integrated into Roon) is working correctly again…
(see “similar” problem/behaviour at: Tidal - "error loading page" - always “synching library now” [Ticket In])

So please can you help me on these two issues?
Further please also could you release a complete list of all ports or configurations which have to be done in the internet router?

Hello @Daniel_Rissmann and welcome to the Roon forum.

Please notice that this is the Roon forum and not the Innuos forum. You should direct your Innuos related question to the Innuos support or at least move it to #audio-products:innuos sub-forum here.

Which seems to be a question that you can answer by yourself by trying it out.

As far as Roon is concerned – for standard internet router setups no such exceptions have to be configured (connections are opened from the Roon Core to the internet which is usually allowed by default).

Thank you @BlackJack I have moved my questions

Hi @Daniel_Rissmann,

Do these issues only occur when the Innuous is the Core? To help separate weather this is networking-related or specific to the Innuous you might want to try installing Roon on another PC and verify if you’re getting similar issues on the PC.