Problems importing music from NAS

I have imported my whole library with the option “album title from file”.
A LOT of my CDs are either not imported in the library, or in any case do not appear in the search results (this is just an idea - I do not know how to verify the existence in the roon library of a specific album).
There are NO illegal characters in the file/track names.
Is there any limitation on the length of the path-name (incl track name)?
Any suggestions anybody?
Could I transfer to somebody a couple of the ripped files to check if they import correctly in your roon library?

Hi @Jan_Leysen,

First, I’d like to point out some documentation we have that may be helpful here. In our KB we have an article about Skipped Files and an article about why some files might be missing from Roon .

If you go to Settings > Library > Skipped Files do you see any of your missing files there?

I’d like to recommend looking at a couple of specific examples of tracks that did not get imported into Roon. Are they supported files? Are they showing up in Skipped Files? If it looks like they should be importing, let me know! Screenshots of these files in their storage location would be helpful for discovering what may be happening.