Problems with Roon seeing my tags correctly

Content you’re reporting an issue with

Have you made any edits to this content in Roon?

Is this content from local files, TIDAL, or Qobuz?

Screenshot of import settings

Description of the issue

Evening all!

So, I keep seeing the wrong information in the wrong places & it’s driving me nuts.

Here is my tagging software with the “album artist” column empty:

When I go back to Roon, it has inserted the “primary artist” (Various Artists) into the “album artist” space, when that slot should be empty (although it wouldn’t bother me if it duplicates it by default).

If I add my required entry into the “album artists” field:

Roon gives me this:

It also seems to have added it to the “Primary Artist” field.

So, in order to get the correct thing, I end up with this utter dog’s dinner:

I’ve jumped through the usual hoops (rescanned the album, rescanned the library, cleared the cache, restarted, cleaned up the library).

If there’s anything else I could try, I’d really appreciate the help.

Cheers! :slight_smile:

I’ve read through your post about three times now and I’m not sure I’m 100% clear on what you’re trying to achieve. Roon is correctly stating that the album artist is ‘Various artists’ (as there are several contributors). In a similar vein, ‘OST, DC 1992-09>95-09’ is not a recognised artist so you will need to add it manually. Could you explain what you expect Roon should be doing with this album?

1 Like

Sure thing…

The Primary Artist is set to Various Artists, which is correct.

The Album Artist should be set to “OST, DC 1992-09>95-09”.

Roon is adding “Various Artists” next to my “Album Artist” entry, which I haven’t asked it to do & it’s putting my “Album Artist” entry next to the primary artists, which I haven’t asked it to do.

The only way I can get it to do what I want is to click on the spurious entry in the “Primary Artist” field to make it red & type my own “Album Artist” entry in the box provided, to override Roon’s double entry bookkeeping!

Basically, it’s just not seeing the metatags that I’ve provided.


Have you tried modifying Settings → Library → Import Settings to change how Roon handles ‘Album artist’? I leave this to Roon, as below, but you might be better off setting it to ‘Prefer file’ if you’ve already tagged your files before import.

Note: if you do change the import settings Roon will (I think) rescan your entire library based on the new setting, so it might take a while.

I have everything set to “prefer file”. :slight_smile:

In which case I’m out of ideas. Hopefully support will have something useful to add.

Thank you. It’s no biggie. I have a workaround, I’m just curious as to why it’s happening. :slight_smile:

1 Like

As I already told you before, “Prefer file” is not “Use my file tags only”. You are fighting Roon. Fighting might become exhausting over time.

Hardly fighting. I can type exactly what I want in the box provided & Roon’s “richness” can do one. But thanks for the reminder. It’s good to know that the problem doesn’t lie with my software or tags. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.